Bug 66283 - Add ability to set a dhcpcd timeout for ifup script
Add ability to set a dhcpcd timeout for ifup script
Status: CLOSED DUPLICATE of bug 64507
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
http://www.linuxquestions.org/questio...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-07 02:34 EDT by Brian "netdragon" Bober
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-07 02:37:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian "netdragon" Bober 2002-06-07 02:34:40 EDT
Description of Problem:
Add ability to set a delay period for dhcpcd for the /sbin/ifup script

Version-Release number of selected component (if applicable):
7.2



http://www.linuxquestions.org/questions/history/19491

I altered the /sbin/ifup file to allow you to add DHCP_CLIENT_TIMEOUT to any 
ifcfg-eth* file (such as /etc/sysconfig/network-scripts/ifcfg-eth0

Can you please build this into the Redhat distribution (and possibly add this 
to the kernel for all distributions)? (I'm not entirely sure if its 100% 
correctly done, but it works for me ;-)

excerpt /sbin/ifup

if [ -n "${DYNCONFIG}" ]; then
PUMPARGS=$PUMPARGS
#--------------------------------------
# Brian Bober
# Hacked to add ability for DHCP_CLIENT_TIMEOUT (in seconds)
# variable to /etc/sysconfig/network-scripts/ifcfg-eth* scripts
#--------------------------------------
if [ -n "${DHCP_CLIENT_TIMEOUT}" ]; then
DHCPCDARGS="${DHCPCDARGS} -t ${DHCP_CLIENT_TIMEOUT}"
fi
#--------------------------------------
# End Hack
#--------------------------------------
DHCPCDARGS="$DHCPCDARGS -n"
if [ -n "${DHCP_HOSTNAME}" ]; then
PUMPARGS="${PUMPARGS} -h ${DHCP_HOSTNAME}"
DHCPCDARGS="${DHCPCDARGS} -h ${DHCP_HOSTNAME}"
fi
if [ -n "${NEEDHOSTNAME}" ]; then
PUMPARGS="${PUMPARGS} --lookup-hostname"
Comment 1 Brian "netdragon" Bober 2002-06-07 02:37:27 EDT
By delay, I meant timeout
Comment 2 Elliot Lee 2002-06-20 12:54:03 EDT

*** This bug has been marked as a duplicate of 64507 ***

Note You need to log in before you can comment on or make changes to this bug.