This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 645232 - qemu-kvm can not quit after poweroff rhel3.9 smp guest
qemu-kvm can not quit after poweroff rhel3.9 smp guest
Status: CLOSED DUPLICATE of bug 516674
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Gleb Natapov
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-10-21 01:02 EDT by Mike Cao
Modified: 2013-12-08 19:51 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 11:44:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen dump (18.37 KB, image/png)
2010-10-21 01:38 EDT, Mike Cao
no flags Details

  None (edit)
Description Mike Cao 2010-10-21 01:02:02 EDT
Description of problem:


Version-Release number of selected component (if applicable):
host:
# uname -r
2.6.18-227.el5
# rpm -q kvm
kvm-83-205.el5
Guest:
#uname -r
2.4.21-65.ELsmp

How reproducible:
100%

Steps to Reproduce:
1.start rhel3u9 (kernel is kernel-smp-2.4.21-65.EL.athlon.rpm)
CLI:/usr/libexec/qemu-kvm -M rhel5.6.0 -m 2048 -smp 1 -name RHEL3U9_32 -uuid bfebb7aa-e58c-c7bb-b667-06b61b16fab7 -boot c -drive file=/home/rhel3u9_32,if=virtio,boot=on,format=raw,cache=none -net nic,macaddr=54:52:00:14:cf:39,vlan=0,model=virtio -net tap,script=/etc/qemu-ifup,vlan=0 -serial pty -parallel none -usb -vnc :3 -k en-us -monitor stdio
2.in the guest #poweroff

  
Actual results:
after step2 ,qemu-kvm can not quit.

Expected results:


Additional info:
1.tried on AMD host.
2tried with guest kernel 2.4.21-65 (kernel-2.4.21-65.EL.athlon.rpm) not hit this issue.
Comment 1 Mike Cao 2010-10-21 01:38:50 EDT
Created attachment 454724 [details]
screen dump
Comment 2 Chao Yang 2010-10-21 06:17:13 EDT
host:
# uname -r
2.6.18-227.el5
# rpm -q kvm
kvm-83-205.el5



tried on Intel host with rhel3u9 32bits guest (kernel 2.4.21-65.ELhugemem),also hit this issue
Comment 4 Gleb Natapov 2010-11-10 11:44:08 EST
Dup. Would be nice to try to find similar bug before opening another one.

*** This bug has been marked as a duplicate of bug 516674 ***

Note You need to log in before you can comment on or make changes to this bug.