Bug 645295 - configuration destroys mdns resolver configuration
configuration destroys mdns resolver configuration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
rawhide
Unspecified Unspecified
low Severity high
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
: 676698 700498 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-21 05:21 EDT by Tomasz Torcz
Modified: 2011-05-13 10:58 EDT (History)
7 users (show)

See Also:
Fixed In Version: authconfig-6.1.12-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-23 12:18:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomasz Torcz 2010-10-21 05:21:50 EDT
Description of problem:
I've used system-config-auth to configure user authentication to use LDAP. Afterwards, I've noticed that hosts in my network are no longer resolved.  I've found that SSS configuration overwritten /etc/nsswitch.conf and removed all entries from nss-mdns package:

# diff -u nsswitch.conf.bak nsswitch.conf
--- nsswitch.conf.bak	2009-07-21 10:46:47.323901956 +0200
+++ nsswitch.conf	2010-10-20 11:05:24.433850339 +0200
@@ -30,12 +30,12 @@
 #shadow:    db files nisplus nis
 #group:     db files nisplus nis
 
-passwd:     files
-shadow:     files
-group:      files
+passwd:     files sss
+shadow:     files sss
+group:      files sss
 
 #hosts:     db files nisplus nis dns
-hosts:      files mdns4_minimal [NOTFOUND=return] dns
+hosts:      files dns
 
 # Example - obey only what nisplus tells us...
 #services:   nisplus [NOTFOUND=return] files
@@ -54,10 +54,10 @@
 rpc:        files
 services:   files
 
-netgroup:   nisplus
+netgroup:   files sss
 
 publickey:  nisplus
 
-automount:  files nisplus
+automount:  files ldap
 aliases:    files nisplus


Version-Release number of selected component (if applicable):
sssd-1.4.0-2.fc15.x86_64



Please note that hosts: line was damaged - mdns4_minimal was removed.
I believe this entry is added my nss-mdns package.
Comment 1 Jakub Hrozek 2010-10-21 06:44:07 EDT
Sorry, but it is a little unclear to me what the actual problem here is.

If it is the fact that the hosts: line got changed, I think that would be authconfig bug and needs to be reassigned.

But there is another thing you might have hit - SSSD (or more precisely the underlying resolver library it uses) does not support resolving hosts from any other database than dns or files. So if your servers are resolvable via mdns, SSSD would not see them.
Comment 2 Tomasz Torcz 2010-10-21 06:50:35 EDT
You are right, it is probably system-config-authentication which overwrites nsswitch.conf.

And destroying content of this line is the problem.
Comment 3 Jeff Bastian 2011-02-10 15:45:44 EST
*** Bug 676698 has been marked as a duplicate of this bug. ***
Comment 4 Stephen Gallagher 2011-05-13 10:58:28 EDT
*** Bug 700498 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.