Bug 64555 - mrtg need not append to /etc/crontab
mrtg need not append to /etc/crontab
Status: CLOSED DUPLICATE of bug 51812
Product: Red Hat Linux
Classification: Retired
Component: mrtg (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-07 17:56 EDT by Joshua Jensen
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-21 11:42:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2002-05-07 17:56:18 EDT
Description of Problem:

[root@mule valhalla]# rpm -q mrtg --scripts
postinstall scriptlet (through /bin/sh):
if ! grep '* * * * root /usr/bin/mrtg' /etc/crontab > /dev/null; then
	echo "" >> /etc/crontab
	echo "0-59/5 * * * * root /usr/bin/mrtg /etc/mrtg/mrtg.cfg" >> /etc/crontab
fi

Why must crontab be appended to?  How about simply creating a file in
/etc/cron.d/ (just like we do with the sysstat file)?

Thank you.


Version-Release number of selected component (if applicable):

stock 7.3
Comment 1 Tom Wood 2002-05-21 11:42:41 EDT
This behavior of modifying /etc/crontab has another undesirable effect in that 
if one runs mrtg daemonized (with the "RunAsDaemon: y" in the mrtg.cfg file), 
this is unneeded and produces undesirable results.  Also, running daemonized 
with a config file other than /etc/mrtg.cfg results in conflicts between the 
daemonized version and the crontab runs, especially if the RedHat-expected 
/etc/mrtg.cfg isn't the same as the daemonized version's config file. 
 
My bottom line is that there should be no assumption in this package that this 
is to be run from crontab.  This causes nothing but grief for those of us 
running mrtg daemonized.
Comment 2 Joe Orton 2002-06-14 10:49:15 EDT

*** This bug has been marked as a duplicate of 51812 ***

Note You need to log in before you can comment on or make changes to this bug.