Bug 64609 - redhat 7.3 upgrade from 7.2 messed up boot drive info
redhat 7.3 upgrade from 7.2 messed up boot drive info
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: 64610 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2002-05-08 12:23 EDT by adler
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-12-29 01:16:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
working grub.conf file, the one I edited by hand (746 bytes, text/plain)
2002-05-08 12:27 EDT, adler
no flags Details
broken grub.conf file. The one generated by the upgrade (746 bytes, text/plain)
2002-05-08 12:30 EDT, adler
no flags Details

  None (edit)
Description adler 2002-05-08 12:23:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
I don't have all the details, but basically I had to modify the grub.config file
and do a grub-install in order to get grub running properly after doing an
upgrade form 7.2 to 7.3.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.have your system boot from a scsi disk (sda)
2.install a promise technologies tx2 raid controller, have a disk running off of it.
3.upgrade from 7.2 to 7.3

Actual Results:  the grub part of the install thought the boot disk was the ide
drive I had hanging off my promis tx2 ata raid controller. Therefore, grub
wasn't able to boot linux. (Had to create a boot floopy to fix the problem.)

Additional info:

my guess is that what ever software is used to determine which is the boot
drive, didn't work well. I'm not sure if this is grubs fault or the redhat
upgrade software's fault.

I even tried the following. After doing the full upgrade and my system wouldn't
boot, I reinstalled (or better said re-upgrade) redhat 7.3. (I forced the
installation of the kernel packages since the grub part of the install needs
this info to build a grub.config file) At the point of the installation where it
asks what it should do regarding the boot loader, I chose the 3rd option, which
was to completely reinstall grub. This didn't work. finally after booting from
the boot disk, I modified the grub.config file by hand, did a grub-install and
now my system is working
Comment 1 adler 2002-05-08 12:27:55 EDT
Created attachment 56685 [details]
working grub.conf file, the one I edited by hand
Comment 2 adler 2002-05-08 12:30:02 EDT
Created attachment 56686 [details]
broken grub.conf file. The one generated by the upgrade
Comment 3 Jeremy Katz 2002-05-08 12:30:32 EDT
*** Bug 64610 has been marked as a duplicate of this bug. ***
Comment 4 Scott Dowdle 2002-05-09 17:47:07 EDT
I experienced this as well... upgrading from a 7.2 system that I think had grub
on it... I picked Upgrade Bootloader during the upgrade... and then I had Lilo.
 I could be mistaken... but in any event Lilo was the default bootloader.  I did
a grub-install.  The /etc/grub.conf file was not valid.  I had to edit it to get
it working.  Other upgrades worked fine as did a clean install.

Sorry for the vague information but I don't have much to go on after an upgrade.
Comment 5 Jeremy Katz 2002-06-04 00:04:50 EDT
What does the /boot/grub/device.map contain?  Also, unfortunately, PC hardware
doesn't really expose what bios order is so this is hard to guess, so in future
releases, we will have a way to change what the bios order of your drives is
while installing.
Comment 6 adler 2002-06-04 10:09:31 EDT
[root@newadler root]# cat /boot/grub/device.map 
# this device map was generated by anaconda
(fd0)     /dev/fd0
(hd0)     /dev/sda
Comment 7 Jeremy Katz 2002-12-29 01:16:51 EST
This should be fixed with current rawhide-ish packages

Note You need to log in before you can comment on or make changes to this bug.