Bug 64610 - redhat 7.3 upgrade from 7.2 messed up boot drive info
redhat 7.3 upgrade from 7.2 messed up boot drive info
Status: CLOSED DUPLICATE of bug 64609
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 12:23 EDT by adler
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-08 12:23:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description adler 2002-05-08 12:23:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
I don't have all the details, but basically I had to modify the grub.config file
and do a grub-install in order to get grub running properly after doing an
upgrade form 7.2 to 7.3.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.have your system boot from a scsi disk (sda)
2.install a promise technologies tx2 raid controller, have a disk running off of it.
3.upgrade from 7.2 to 7.3
	

Actual Results:  the grub part of the install thought the boot disk was the ide
drive I had hanging off my promis tx2 ata raid controller. Therefore, grub
wasn't able to boot linux. (Had to create a boot floopy to fix the problem.)

Additional info:

my guess is that what ever software is used to determine which is the boot
drive, didn't work well. I'm not sure if this is grubs fault or the redhat
upgrade software's fault.

I even tried the following. After doing the full upgrade and my system wouldn't
boot, I reinstalled (or better said re-upgrade) redhat 7.3. (I forced the
installation of the kernel packages since the grub part of the install needs
this info to build a grub.config file) At the point of the installation where it
asks what it should do regarding the boot loader, I chose the 3rd option, which
was to completely reinstall grub. This didn't work. finally after booting from
the boot disk, I modified the grub.config file by hand, did a grub-install and
now my system is working
Comment 1 Jeremy Katz 2002-05-08 12:30:37 EDT

*** This bug has been marked as a duplicate of 64609 ***

Note You need to log in before you can comment on or make changes to this bug.