Bug 646113 - Can't resume again, after having resumed from suspend (and other issues: libupower-glib-WARNING: Couldn't suspend: not authorized)
Can't resume again, after having resumed from suspend (and other issues: libu...
Status: CLOSED DUPLICATE of bug 643367
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-24 08:20 EDT by Tobias Mueller
Modified: 2010-11-16 19:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-16 19:59:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg after resuming from suspend (87.54 KB, application/octet-stream)
2010-10-24 08:20 EDT, Tobias Mueller
no flags Details

  None (edit)
Description Tobias Mueller 2010-10-24 08:20:37 EDT
Created attachment 455334 [details]
dmesg after resuming from suspend

Description of problem:
After resuming from suspend my system behaves weirdly. I can't do any sound and I can't resume or suspend the machine forcing me to reboot.

Version-Release number of selected component (if applicable):


How reproducible:
Not always, but this is the second time I encounter this issue. It happens after resuming from a suspend. Maybe the machine was suspended too long?

Steps to Reproduce:
1.
2.
3.
  
Actual results:
I can't play songs in rhythmbox: The play button is clicked but the indicator doesn't advance. I can't play with mplayer with the same symptoms and I get this in /var/log/messages:
Oct 24 13:59:26 bigbox pulseaudio[2291]: sink-input.c: Failed to create sink input: sink is suspended.
Oct 24 14:00:32 bigbox dbus: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1
.223" (uid=1000 pid=23358 comm="/usr/bin/python) interface="org.freedesktop.DBus.Introspectable" member="Int
rospect" error name="(unset)" requested_reply=0 destination=":1.73" (uid=1000 pid=28049 comm="/usr/bin/python))
Oct 24 14:00:36 bigbox dbus: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.223" (uid=1000 pid=23358 comm="/usr/bin/python) interface="org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)" requested_reply=0 destination=":1.53" (uid=1000 pid=2571 comm="/usr/bin/seapplet))
Oct 24 14:01:36 bigbox pulseaudio[2291]: sink-input.c: Failed to create sink input: sink is suspended.
Oct 24 14:03:55 bigbox gnome-session[2170]: libupower-glib-WARNING: Couldn't suspend: not authorized
Oct 24 14:03:55 bigbox gnome-session[2170]: WARNING: Unexpected suspend failure: not authorized

The last warnings are caused by me trying to suspend the machine. The screensaver locks and the screen blanks but then nothing happens and I can enter my password to unlock the screen.

Expected results:
I expected the system components to not lose connection or authorization from where ever. Especially after I logged in through gnome-screensaver after resume.

Additional info:
I'll attach my dmesg.
Comment 1 Tobias Mueller 2010-10-24 08:30:01 EDT
I found http://bugs.gentoo.org/show_bug.cgi?id=285947 which leads to https://bugzilla.gnome.org/show_bug.cgi?id=595963 which reads:
> Agreed, this isn't a gnome-power-manager issue. You need to check
> ConsoleKit is marking your session active, and polkit-1 is installed correctly.

hm. How can I do that?
And would that affect my ability to make sound with PulseAudio, too?
Comment 2 Tobias Mueller 2010-10-30 16:51:59 EDT
FWIW: Switching to vt2 and back to X server makes it work again. Lennart said this is a CK issue and there is a bug about that.
Comment 3 Tobias Mueller 2010-11-06 09:21:04 EDT
This is probably bug 643367
Comment 4 Lennart Poettering 2010-11-16 19:58:08 EST
*** Bug 650955 has been marked as a duplicate of this bug. ***
Comment 5 Lennart Poettering 2010-11-16 19:59:02 EST

*** This bug has been marked as a duplicate of bug 643367 ***

Note You need to log in before you can comment on or make changes to this bug.