Bug 650955 - No sound after suspend
No sound after suspend
Status: CLOSED DUPLICATE of bug 643367
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-08 08:39 EST by Mildred
Modified: 2010-11-17 05:57 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-16 19:58:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mildred 2010-11-08 08:39:37 EST
Description of problem: Sometimes, sound siappears. It happens generally after an update of the system.

Version-Release number of selected component (if applicable): pulseaudio-0.9.21-6.fc13.x86_64

How reproducible: sometimes


Additional info:
----------------

If I run alsamixer in a terminal emulator and press F6 to select the soundcard I want, I only get the PulseAudio emulated soundcard for ALSA (default). Generally, I would see both soundcards.

If I unset the $DISPLAY variable, alsamixer see my soundcard again (in addition to the default one which I believe is PulseAudio).

Playing a sound if I have a $DISPLAY variable set doesn't work (with mplayer for example). If I unset $DISPLAY it works (For security I asked for my physical soundcard using -ao alsa:device=hw=0)

Logging out and back in generally solves the problem. I just saw that the problem resolved itself without doing anything (except killing some pulseaudio daemons that were restarted anyway).

Another thing I noticed is that Totem or mplayer refuse to play a video (the sounds blocks it). strace tells me that a write failed with EAGAIN. Adobe Flash player instead plays the video with no sound (they probably didn't get the EAGAIN part right).

If you can do something with that I'd be happy. I don't quite understand the problem yet except that it happened during the past month quite a lot (I was using F14 at that time and supposed that the updates broke something within the living processes and that was all).
Comment 1 Mildred 2010-11-11 09:01:17 EST
I think I understand what happens. What I wrote above is wrong. $DISPLAY doesn't help at all. What helps is switching to a text console and back to Xorg.

I think this sound loss happens after sleeping or hibernation. ConsoleKit must have deregistered the current display and when the computer wakes up, thinks the display isn't used.

As a consequence, the audio is disabled.

Last time this happened, I had no more battery power and the computer put itself to hibernation automatically.
Comment 2 Lennart Poettering 2010-11-16 19:57:33 EST
*** Bug 653005 has been marked as a duplicate of this bug. ***
Comment 3 Lennart Poettering 2010-11-16 19:58:08 EST

*** This bug has been marked as a duplicate of bug 646113 ***
Comment 4 Harald Hoyer 2010-11-17 05:57:18 EST

*** This bug has been marked as a duplicate of bug 643367 ***

Note You need to log in before you can comment on or make changes to this bug.