Bug 64614 - Very poor performance with antialiasing in gv
Very poor performance with antialiasing in gv
Status: CLOSED DUPLICATE of bug 58978
Product: Red Hat Linux
Classification: Retired
Component: gv (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 13:08 EDT by Need Real Name
Modified: 2014-03-16 22:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-08 15:43:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-08 13:08:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
gv is very slow rendering documents with antialiasing turned on.  Performance in
older versions (RH 7.2) was much faster.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open a postscript document with gv.
2. Turn on antialiasing.
3. Watch it redraw.
	

Actual Results:  Very slow rendering of document (on a 1.3Ghz Athlon).

Additional info:

ggv doesn't suffer from the same slowness (but it can't open many PDFs that gv
can), nor did the version of gv that came with RH 7.2.
Comment 1 Sammy 2002-05-08 15:27:46 EDT
I have reported this earlier for rawhide...if you get the source rpm and 
remove the "alpha" patch it'll go back to being fast again. 
 
What version of gs are you using? I ask this because I am not sure why 
we have the alpha patch that seems to change some gs options.
Comment 2 Need Real Name 2002-05-08 15:43:21 EDT
I'm personally too lazy to mess with the source rpm, but thanks for the tip.

I'm using the version of ghostscript that comes with RH 7.3.
  $ rpm -q ghostscript
  ghostscript-6.52-8
Comment 3 Bill Nottingham 2002-06-12 01:48:17 EDT

*** This bug has been marked as a duplicate of 58978 ***

Note You need to log in before you can comment on or make changes to this bug.