Bug 64645 - Unable to compile as sym53c8xx_2 a module
Summary: Unable to compile as sym53c8xx_2 a module
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 64985 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-09 00:50 UTC by Samuel Flory
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-16 20:45:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Samuel Flory 2002-05-09 00:50:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020427

Description of problem:
When compiling the kernel with sym53c8xx_2 built into the kernel the following
happens.

ld -m elf_i386  -r -o scsidrv.o scsi_mod.o aic7xxx/aic7xxx_drv.o
sym53c8xx_2/sym53c8xx.o sd_mod.o
ld: cannot open sym53c8xx_2/sym53c8xx.o: No such file or directory
make[3]: *** [scsidrv.o] Error 1
make[3]: Leaving directory `/stuff/src/linux-2.4.18-3/drivers/scsi'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/stuff/src/linux-2.4.18-3/drivers/scsi'
make[1]: *** [_subdir_scsi] Error 2
make[1]: Leaving directory `/stuff/src/linux-2.4.18-3/drivers'
make: *** [_dir_drivers] Error 2


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.change sym53c8xx_2 to compile directly into the kernel
2. make dep clean bzImage

	

Additional info:

Comment 1 Samuel Flory 2002-05-09 17:26:33 UTC
in driver/scsi/Makefile it should be like this:
ifeq ($(CONFIG_SCSI_SYM53C8XX_2),y)
  obj-$(CONFIG_SCSI_SYM53C8XX_2)        += sym53c8xx_2/sym53c8xx_2.o
endif

not this
ifeq ($(CONFIG_SCSI_SYM53C8XX_2),y)
  obj-$(CONFIG_SCSI_SYM53C8XX_2)        += sym53c8xx_2/sym53c8xx.o
endif


Comment 2 Michael K. Johnson 2002-05-16 20:45:01 UTC
*** Bug 64985 has been marked as a duplicate of this bug. ***

Comment 3 Arjan van de Ven 2002-05-21 11:06:54 UTC
fixed for the next build


Note You need to log in before you can comment on or make changes to this bug.