Bug 646870 - misaddresed user-space probes on prelinked shared libraries on i686 (REL)
misaddresed user-space probes on prelinked shared libraries on i686 (REL)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: systemtap (Show other bugs)
5.6
i686 Unspecified
low Severity high
: rc
: ---
Assigned To: Frank Ch. Eigler
qe-baseos-tools
:
Depends On:
Blocks: 646871
  Show dependency treegraph
 
Reported: 2010-10-26 10:23 EDT by Frank Ch. Eigler
Modified: 2011-07-21 07:11 EDT (History)
3 users (show)

See Also:
Fixed In Version: systemtap-1.3-5.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 646871 (view as bug list)
Environment:
Last Closed: 2011-07-21 07:11:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2010-10-26 10:23:42 EDT
Due to a suspected problem in the way systemtap/elfutils
compute PC addresses to place int3 probe breakpoints into
prelinked shared libraries, sometimes the wrong instruction
is modified.  This can lead to lost probes, or segmentation
violations, or more subtle errors.  This problem appears to
exist in all versions of systemtap.

"prelink -u /usr/lib/libFOO.so" corrects the miscalculations,
as a temporary workaround.

This issue is being tracked upstream at
http://sourceware.org/bugzilla/show_bug.cgi?id=12141
Comment 1 Frank Ch. Eigler 2010-11-29 11:37:01 EST
A future refresh of systemtap can update its bundled elfutils to version 0.150 to fix this problem.
Comment 4 Frank Ch. Eigler 2011-05-13 09:06:50 EDT
Please copy notes from bug #652858, which fixed the corresponding issues in RHEL6.
Comment 6 errata-xmlrpc 2011-07-21 07:11:08 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1044.html

Note You need to log in before you can comment on or make changes to this bug.