Bug 646871 - misaddresed user-space probes on prelinked shared libraries on i686 (REL)
misaddresed user-space probes on prelinked shared libraries on i686 (REL)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: systemtap (Show other bugs)
6.1
i686 Unspecified
low Severity high
: rc
: ---
Assigned To: Frank Ch. Eigler
qe-baseos-tools
:
Depends On: 646870 652857 652858
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-26 10:25 EDT by Frank Ch. Eigler
Modified: 2011-05-19 09:54 EDT (History)
4 users (show)

See Also:
Fixed In Version: systemtap-1.4-1.el6
Doc Type: Bug Fix
Doc Text:
n/a, see bug #652858.
Story Points: ---
Clone Of: 646870
: 652857 652858 (view as bug list)
Environment:
Last Closed: 2011-05-19 09:54:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 12141 None None None Never

  None (edit)
Description Frank Ch. Eigler 2010-10-26 10:25:28 EDT
+++ This bug was initially created as a clone of Bug #646870 +++

Due to a suspected problem in the way systemtap/elfutils
compute PC addresses to place int3 probe breakpoints into
prelinked shared libraries, sometimes the wrong instruction
is modified.  This can lead to lost probes, or segmentation
violations, or more subtle errors.  This problem appears to
exist in all versions of systemtap.

"prelink -u /usr/lib/libFOO.so" corrects the miscalculations,
as a temporary workaround.

This issue is being tracked upstream at
http://sourceware.org/bugzilla/show_bug.cgi?id=12141
Comment 2 Frank Ch. Eigler 2010-11-13 21:04:18 EST
elfutils patch in hand
Comment 4 Frank Ch. Eigler 2011-01-17 10:30:50 EST
relies on elfutils 0.151 (or perhaps 0.150)
Comment 10 Frank Ch. Eigler 2011-05-12 09:54:50 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
n/a, see bug #652858.
Comment 11 errata-xmlrpc 2011-05-19 09:54:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0651.html

Note You need to log in before you can comment on or make changes to this bug.