Bug 646909 - enhance default configuration of allow for Shift-PgUp/PgDown within xterm
Summary: enhance default configuration of allow for Shift-PgUp/PgDown within xterm
Keywords:
Status: CLOSED DUPLICATE of bug 123504
Alias: None
Product: Fedora
Classification: Fedora
Component: screen
Version: rawhide
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-26 15:46 UTC by Florian La Roche
Modified: 2011-02-04 15:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-04 15:44:18 UTC


Attachments (Terms of Use)

Description Florian La Roche 2010-10-26 15:46:00 UTC
Description of problem:

Maybe it would make sense to add the following into the default
screen configuration to allow Shift-PgUp and Shift-PgDown to
also work within an xterm:
  termcapinfo xterm|xterms|xs|rxvt ti@:te@
  defscrollback 2000

regards,

Florian La Roche




How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Miroslav Lichvar 2011-02-04 15:44:18 UTC
This would disable the alternate buffer, which some users prefer to have, see bug #544614 for an example where it was broken.

Another way how to disable the buffer is to set xterm's titeInhibit resource.

*** This bug has been marked as a duplicate of bug 123504 ***


Note You need to log in before you can comment on or make changes to this bug.