Bug 64695 - Xconfigurator --kickstart fails to create config file
Summary: Xconfigurator --kickstart fails to create config file
Status: CLOSED DUPLICATE of bug 39745
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-09 19:24 UTC by Peter Fales
Modified: 2006-03-11 03:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here's a specific patch for 4.10.7-1 that makes it work for us. (1.69 KB, patch)
2002-08-12 22:33 UTC, andrew m. boardman
no flags Details | Diff

Description Peter Fales 2002-05-09 19:24:54 UTC
Description of Problem:

When I run "Xconfigurator --kickstart" to automate the creation of the 
XF86Config-4 file, it fails.   Investigation reveals that it is failing to 
probe the amount of memory available, and that looks to be due to a change
in the way XFree86 4.2 handles debug output.  

Version-Release number of selected component (if applicable):

Xconfigurator-4.10.7-1


How Reproducible:

Consistently reproducable



Steps to Reproduce:
1. Remove /etc/X11/XF86Config-4
2. run "Xconfigurator --kickstart"
 

Actual Results:

No /etc/X11/XF86Config-4 file is created

Expected Results:

An /etc/X11/XF86Config-4 file should be created

Additional Information:
	
In examining the Xconfigurator source code, it looks like it is running
"Xfree86 --probeonly" and grepping stderr for the string "videoRAM: ".  This
worked under XFree86 4.0, but under 4.2, the debug output goes to a logfile
instead of stderr.  I was able to get Xconfigurator to work by replacing
all the lines that look like


	Xconfigurator --probeonly ... 2> tmpfile

with

	Xconfigurator --probeonly ... -logfile tmpfile 2> /dev/null

Comment 1 Mike A. Harris 2002-05-30 22:17:01 UTC
*** Bug 65487 has been marked as a duplicate of this bug. ***

Comment 2 andrew m. boardman 2002-08-12 22:33:07 UTC
Created attachment 70164 [details]
Here's a specific patch for 4.10.7-1 that makes it work for us.

Comment 3 Isaiah Weiner 2002-12-21 19:05:24 UTC
When can an errata be expected?  This is an issue with Cisco, as well.

Comment 5 Mike A. Harris 2003-04-20 17:04:46 UTC

*** This bug has been marked as a duplicate of 39745 ***

Comment 6 Red Hat Bugzilla 2006-02-21 18:48:52 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.