Bug 64713 - xsane can't find scanner
xsane can't find scanner
Status: CLOSED DUPLICATE of bug 64964
Product: Red Hat Linux
Classification: Retired
Component: sane-backends (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-09 17:25 EDT by Scott Dowdle
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-15 01:02:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dowdle 2002-05-09 17:25:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.1 (X11; Linux i686; U;) Gecko/20020417

Description of problem:
xsane can't find scanner.  Previous version did just fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run xsane as root (to avoid permissions/ownership issues)
2. it can't find the scanner device

	

Actual Results:  Can't scan anything with SCSI aic7xxx based HP C2500A scanner

Expected Results:  Should find scanner, previous versions did

Additional info:

Upgraded from RHL 7.2.  All of the SCSI devices LUNs changed.  cdrecord -scanbus
reports (output cleaned up for insertion here):

scsibus0:
 0,3,0 3) 'ECRIX' 'VXA-1' '2B7B' Removable Tape
scsibus1:
 1,2,0 102) 'HP' 'C2500A' '3332' Processor
scsibus2:
 2,0,0 200) 'PHILIPS' 'PCRW1208' '1.2' Removable CD-ROM

Tape drive and IDE CD-R drive work fine.

Think I have some crufty config files somewhere... and can't figure out how to
make the scanner work again.

More info from dmesg (edited for insertion here):

SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
PCI: Found IRQ 10 for device 02:00.0
PCI: Found IRQ 11 for device 02:01.0
PCI: Sharing IRQ 11 with 00:1f.3
scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.5
        <Adaptec 2940 Ultra SCSI adapter>
        aic7880: Ultra Wide Channel A, SCSI Id=7, 16/253 SCBs

scsi1 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.5
        <Adaptec 2902/04/10/15/20/30C SCSI adapter>
        aic7850: Single Channel A, SCSI Id=7, 3/253 SCBs

Vendor: ECRIX	  Model: VXA-1   Rev: 2B7B
Type:
Sequential-Access
 ANSI SCSI revision: 02

Vendor: HP	  Model: C2500A  Rev: 3332
Type:
Processor
	 ANSI SCSI revision: 02

...later...

st: Version 20020205, bufsize 32768, wrt 30720, max init. bufs 4, s/g segs 16
Attached scsi tape st0 at scsi0, channel 0, id 3, lun 0
hdc: ATAPI 48X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
scsi2 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: PHILIPS   Model: PCRW1208  Rev:  1.2
  Type:   CD-ROM                     ANSI SCSI revision: 02

...later...

Attached scsi generic sg1 at scsi1, channel 0, id 2, lun 0,  type 3
(scsi0:A:3): 10.000MB/s transfers (10.000MHz, offset 15)

Thanks in advance for any help.
Comment 1 Peter Klotz 2002-05-15 01:02:35 EDT
I also upgraded from RHL 7.2.
An 'strace xsane' unveils that xsane is not able to load any libraries from
/usr/lib/sane. It seems that several softlinks are missing that xsane looks for.

Creating a softlink like
ln -s libsane-mustek_usb.so.1.0.7 libsane-mustek_usb.so.1
made my Mustek 1200CU USB scanner work.
Comment 2 Tim Waugh 2002-05-15 06:55:05 EDT

*** This bug has been marked as a duplicate of 64964 ***
Comment 3 Scott Dowdle 2002-05-15 17:17:51 EDT
Thank you for the comment.  Simply marking this as a duplicate of another bug
report did NOT email me.  Making a comment DID email me.  Bug 64964 is the
correct bug number for this problem.  The temporary solution noted in the bug
64964 says that simply running /sbin/ldconfig will fix the problem.  It didn't
for me.  I also had to make a symlink.  Not complaining because it was simple
enough to do... and I'm *SO GLAD* to have found a solution here!

Thanks!

Note You need to log in before you can comment on or make changes to this bug.