Bug 64964 - upgrade failes to make link for xsane lib
upgrade failes to make link for xsane lib
Product: Red Hat Linux
Classification: Retired
Component: sane-backends (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
: 64713 64886 64973 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2002-05-15 01:28 EDT by Larry K. Brown
Modified: 2007-04-18 12:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-05-28 08:52:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Larry K. Brown 2002-05-15 01:28:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20020314

Description of problem:
If you install RH7.3 on a clean system the following link is made:
/usr/lib/sane/libsane-epson.so.1 -> libsane-epson.so.1.0.7
However if you UPGRADE from RH7.2 to RH7.3 the above link is not made.
This causes xsane to abort with the following message in /var/log/messages:
kernel: scanner.c: open_scanner(1): Unable to access minor data
with the 1 replaced with 1 - 15.  However 0 is not in the log
and that is where the device is.
Adding the link fixed the problem.

Larry K. Brown

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install RH7.2
2.Edit /etc/sane.d/epson.conf to "usb /dev/usb/scanner0"
3.verify epson 1640 usb scanner works with xsane
4.upgrade with RH7.3
5.verify xsane fails
6.look for /usr/lib/sane/libsane-e* and see if link is present.

Actual Results:  Link was missing

Additional info:
Comment 1 Christoph Breitkopf 2002-05-15 06:47:11 EDT
*** Bug 64973 has been marked as a duplicate of this bug. ***
Comment 2 Tim Waugh 2002-05-15 06:54:59 EDT
*** Bug 64713 has been marked as a duplicate of this bug. ***
Comment 3 Tim Waugh 2002-05-15 06:56:33 EDT
Fixed package will be sane-backends-1.0.7-7.  In the meantime you can run 
'/sbin/ldconfig' as root to work around this problem.
Comment 4 Tim Waugh 2002-05-15 06:57:45 EDT
*** Bug 64886 has been marked as a duplicate of this bug. ***
Comment 5 Michael K. Johnson 2002-05-16 14:05:15 EDT
The workaround doesn't work.  I've just tested it.  It creates links like
lrwxrwxrwx 1 root  root     21 May 16 13:14 libsane-umax.so ->
-rwxr-xr-x 1 root  root 136687 Mar  4 18:31 libsane-umax.so.1.0.7

However, it does not create symlinks with the major version number:
libsane-umax.so.1 -> libsane-umax.so.1.0.7 is not created, and so I
still get
open("/usr/lib/sane/libsane-umax.so.1", O_RDONLY) = -1 ENOENT (No such file or

SANE is completely, 100% unusable with this bug, so it is my opinion that
this should go out as a RHBA ASAP.
Comment 6 Tim Waugh 2002-05-16 16:50:47 EDT
It worked when I tested it (install 1.0.5, upgrade to 1.0.7, run ldconfig). 
Does sane-backends-1.0.7-7 work for you?
Comment 7 Michael K. Johnson 2002-05-17 12:54:36 EDT
I tested it on two machines, and it didn't work on either machine.
I checked /etc/ld.so.conf to make sure that the directory was listed.

Yes; at least, it gets the symlinks right.
Comment 8 Sam Varshavchik 2002-05-19 12:49:02 EDT
Rerunning ldconfig does NOT work for me either.

The RPM package installs the complete set of softlinks.  Running ldconfig from
sane-backends's postinstall script blows half of them away.

Comment 9 Tim Waugh 2002-05-24 06:36:56 EDT
*** Bug 65178 has been marked as a duplicate of this bug. ***
Comment 10 Need Real Name 2002-05-27 10:46:33 EDT
More difficulties. Uninstalled 1.07 and all old sane and xsane files.
Reinstalled 1.0.7-6 and xsane 0.84. Ran ldconfig. Nothing works now.
Sane-find-scanner recognizes /dev/sg0 (which is where my scanner is) as " found
USB scanner (UNKNOWN vendor and product)" . Scanimage and xsane say there is no
scanner device on the system. The scanner is listed correctly in /proc/scsi/scsi
as an HP model C6270A on the SCSI channel. Now what can I do. I have no scanner
 and am unable to get my work done! This is an urgent problem for me.
Comment 11 Tim Waugh 2002-05-27 10:51:47 EDT
Please remove xsane and sane-backends, then check that /usr/lib/sane no longer 
exists, then install sane-backends and xsane, but don't run ldconfig.  Check 
SANE is installed correctly with 'rpm -V sane-backends' (you should get no 
Comment 12 Need Real Name 2002-05-27 12:29:13 EDT
I did all you suggested, but still have the problem. I did find that both the
SCSI and the USB are both on IRQ 9. Could this be the problem? How can I change it?
Comment 13 Tim Waugh 2002-05-27 12:32:01 EDT
No, that isn't the problem.  Did 'rpm -V sane-backends' give any output? 
Did this scanner work in Red Hat Linux 7.2?
Comment 14 Need Real Name 2002-05-27 12:36:32 EDT
rpm -V gave no output. Each step went fine, but Xsane does not recognize the
scanner and sane-find-scanner continues to list an unidentified USB sdcanner.
Comment 15 Need Real Name 2002-05-27 12:41:04 EDT
Yes, it worked with RH 7.2 under sane-backends 1.0.5 and xsane 0.82. Upgrade to
1.07 and 0.84 was with the RH 7.3 install. I will note that under RH 7.2 the
first time I ran Xsane for any session resulted in the error that no sane device
was installed. I would run Xsane a second time and it would run fine.
Sane-find-scanner always recognized the HP C6720 under RH 7.2.
Comment 16 Need Real Name 2002-05-28 08:52:08 EDT
Finally got things working by removing sane-backends 1.0.7 and installing sane-
backends 1.0.5 from RH 7.2 disks. Current working set up is RH 7.3, HP C6270A 
SCSI scanner, and Xsane 0.84.
Comment 17 Tim Waugh 2002-06-18 08:04:44 EDT
This is fixed in the current errata package.
Comment 18 Need Real Name 2002-06-19 20:06:46 EDT
Please be advised that the current errata package does not fix this for me. Used
Uptodate to update sane-backends and the system could not identify my scanner.
Continues to work normally with sane-backends 1.0.5. 1.07 doesn't work for me!
Comment 19 Tim Waugh 2002-06-20 02:35:41 EDT
lgoldma@attglobal.net: As I think I might have said to you before in private 
mail, I believe the problem you are seeing is a separate issue to this, 
unrelated to symlinks.  Please open a separate report for it.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.