This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 647241 - Unable to install from an iSCSI volume
Unable to install from an iSCSI volume
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
13
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 652000 669935 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-27 12:48 EDT by Daniel Berrange
Modified: 2011-04-16 16:58 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-virtinst-0.500.6-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-16 16:55:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2010-10-27 12:48:38 EDT
Description of problem:
I attempted to install a guest from virt-manager, selecting a volume from an iSCSI storage pool. This resulted in virtinst creating XML for the disk that looked like

    <disk type='block' device='disk'>
      <driver name='qemu' type='unknown'/>
      <source dev='/dev/disk/by-path/ip-192.168.254.185:3260-iscsi-iqn.2004-04.com.qnap:ts-439proii:iscsi.berrangehome.bf6d84-lun-3'/>
      <target dev='vda' bus='virtio'/>
    </disk>

Note the type='unknown'.

What's going on is that VirtualDisk.py is copying the vol/target/format/@type field from the volume XML across to the guest XML.

It should only do this for volumes that report  type=file. For volumes of type=block, the format refers to the partition table format, so the guest XML should just get  type='raw'

One quick hack change I tried in VirtualDisk.py  set_driver() is:

        elif self.vol_object:
            fmt = None
            if self.type != VirtualDisk.TYPE_BLOCK:
                fmt = _util.get_xml_path(self.vol_object.XMLDesc(0),
                                         "/volume/target/format/@type")
            if drvname == self.DRIVER_QEMU:
                drvtype = _qemu_sanitize_drvtype(self.type, fmt)



Version-Release number of selected component (if applicable):
python-virtinst-0.500.4-1.fc13.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2010-11-10 15:18:57 EST
*** Bug 652000 has been marked as a duplicate of this bug. ***
Comment 2 Ferry Huberts 2010-11-10 15:38:58 EST
sorry for the duplicate, i searched for isci in libvirt...

any idea when this will be fixed? now that rhel6 is out :-)
or should I just apply that hack?
Comment 3 Daniel Berrange 2010-11-10 15:46:58 EST
If you have a problem with this on RHEL6 too, please file a BZ directly against RHEL6 product rather than just Fedora.
Comment 4 Ferry Huberts 2010-11-10 15:56:56 EST
no that's not what I meant. I meant that you might have some more time now that rhel6 is out :-)
haven't tried rhel6 yet, am a bit low on subscriptions :-)
Comment 5 Cole Robinson 2010-11-17 16:06:21 EST
Thanks for the report, fixed upstream:

http://hg.fedorahosted.org/hg/python-virtinst/rev/5b0f7408003b
Comment 6 Cole Robinson 2011-03-23 17:29:31 EDT
*** Bug 669935 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2011-03-31 10:13:04 EDT
python-virtinst-0.500.6-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python-virtinst-0.500.6-1.fc14
Comment 8 Fedora Update System 2011-03-31 10:15:59 EDT
python-virtinst-0.500.4-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/python-virtinst-0.500.4-2.fc13
Comment 9 Fedora Update System 2011-04-01 14:26:41 EDT
Package python-virtinst-0.500.4-2.fc13:
* should fix your issue,
* was pushed to the Fedora 13 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-virtinst-0.500.4-2.fc13'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/python-virtinst-0.500.4-2.fc13
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-04-16 16:55:12 EDT
python-virtinst-0.500.4-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-04-16 16:57:57 EDT
python-virtinst-0.500.6-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.