Bug 647304 - Shift+Space stopped printing nbsp (ZWNJ) character in Fedora 14 (in ir keyboard layout)
Summary: Shift+Space stopped printing nbsp (ZWNJ) character in Fedora 14 (in ir keyboa...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xkeyboard-config
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-27 20:30 UTC by Hedayat Vatankhah
Modified: 2010-11-02 15:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-02 05:26:24 UTC


Attachments (Terms of Use)

Description Hedayat Vatankhah 2010-10-27 20:30:24 UTC
Description of problem:
In Fedora 13 and before, you were able to write zero-width non-joiner character using Shift+Space in "ir" keyboard layout; but it has stopped working with the new symbols file in Fedora 14. I cannot enable that even by changing Gnome keyboard layout settings about what the space character writes. Apparently, the new include "nbsp(zwnj2nb3nnb4)" sentence in symbols/ir doesn't work as expected. 

Version-Release number of selected component (if applicable):
xkeyboard-config-1.9-6.fc14.noarch

How reproducible:
100 %

Steps to Reproduce:
1. Add "ir" keyboard layout in Gnome
2. Try to use Shift+Space to print zwnj when "ir" layout is active
  
Actual results:
Nothing happens at all

Expected results:
It should print a zwnj character

This brings a great inconvenience :(

Comment 1 Peter Hutterer 2010-10-29 05:57:05 UTC
please update to xorg-x11-xkb-utils-7.4-9.fc14.i386 if you haven't already done so. the zwnj only renders <200c> for me when I select an iranian layout but I"m not sure if that's due to me missing some other packages.

Comment 2 Hedayat Vatankhah 2010-10-29 07:49:59 UTC
<200c> is all that is needed! I've tried 7.4-9 and confirm that the bug is fixed there (in 7.4-8 the zwnj doesn't render anything at all). 

Thanks

Comment 3 Hedayat Vatankhah 2010-10-29 15:50:53 UTC
What a pity! I thought that the 7.4-9 - which fixes bug #638244 - has been appeared soon enough to be in Fedora 14. So, F14 will be shipped with many broken keys in some layouts... :(

Comment 4 Peter Hutterer 2010-11-02 05:26:24 UTC
yeah, I know, it's unfortunate but hard to change now. For next time, we need more testing and feedback, especially of different keyboard layouts (I use "us" most of the time). and of course karma votes for fixes.

Comment 5 Hedayat Vatankhah 2010-11-02 15:55:52 UTC
Yes, I regret forgetting to add karma to this package... :(. Maybe it should be documented as a Common bug? (as it could affect many keyboard layouts)


Note You need to log in before you can comment on or make changes to this bug.