Bug 647669 - jboss-as-5 plugin: jboss-reflect.jar is required by some profileservice client calls and so should be included in the list of client jars returned by ApplicationServerDiscoveryComponent.getAdditionalClasspathUrls()
jboss-as-5 plugin: jboss-reflect.jar is required by some profileservice clien...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Ted Jones
Mike Foley
:
Depends On:
Blocks: 725852 jon30-bugs
  Show dependency treegraph
 
Reported: 2010-10-28 23:53 EDT by Ian Springer
Modified: 2014-06-27 17:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 648788 (view as bug list)
Environment:
SOA-P 5 ER3 / RHQ 3.0.0
Last Closed: 2014-06-27 17:30:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2010-10-28 23:53:14 EDT
(05:37:16 PM) tejones: ips: Now I'm seeing this:  org.rhq.core.util.exception.WrappedRemotingException:java.lang.NoClassDefFoundError: org/jboss/reflect/spi/TypeInfo 
(10:51:17 PM) tejones: ips: Doesn't look like the TypeInfo class is referenced directly by Teiid
(11:06:28 PM) tejones: ips: The TypeInfo class [from jboss-reflect.jar] is referenced by the MetaValueFactory which Teiid uses to unwrap properties
(11:07:59 PM) tejones: ips: So it seems like the jar should be added to the client jars since other plugins will likely do this as well?
(11:09:34 PM) ips: yeah, sounds like it
Comment 1 Ian Springer 2010-10-28 23:54:08 EDT
Fixed in master - commit f637fd4.
Comment 2 Ian Springer 2010-10-29 10:40:59 EDT
Fixed in release-3.0.0 - commit aa672c8.
Comment 3 Charles Crouch 2010-11-02 01:58:19 EDT
Should be tested in master (JON3) by SOA-P team
Comment 4 Corey Welton 2011-01-03 23:26:03 EST
Removing the blocker from the jon241 version of this bug.
Comment 5 Mike Foley 2011-07-08 13:35:18 EDT
tejones .... ips said you were the right person to verify this.
Comment 6 Ian Springer 2011-07-27 12:33:50 EDT
This fix is not needed in the AdminConsole_EAP_5_1 branch, since client jars are not used when the plugin container is running in embedded mode (because all the JBAS classes needed are already in the admin-console.war's classloader).

Note You need to log in before you can comment on or make changes to this bug.