Bug 648788 - JON241: jboss-as-5 plugin: jboss-reflect.jar is required by some profileservice client calls and so should be included in the list of client jars returned by ApplicationServerDiscoveryComponent.getAdditionalClasspathUrls()
JON241: jboss-as-5 plugin: jboss-reflect.jar is required by some profileservi...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Len DiMaggio
:
Depends On:
Blocks: jon241-bugs
  Show dependency treegraph
 
Reported: 2010-11-02 01:56 EDT by Charles Crouch
Modified: 2015-02-01 18:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 647669
Environment:
SOA-P 5 ER3 / RHQ 3.0.0
Last Closed: 2013-08-31 07:10:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2010-11-02 01:56:51 EDT
+++ This bug was initially created as a clone of Bug #647669 +++

(05:37:16 PM) tejones: ips: Now I'm seeing this:  org.rhq.core.util.exception.WrappedRemotingException:java.lang.NoClassDefFoundError: org/jboss/reflect/spi/TypeInfo 
(10:51:17 PM) tejones: ips: Doesn't look like the TypeInfo class is referenced directly by Teiid
(11:06:28 PM) tejones: ips: The TypeInfo class [from jboss-reflect.jar] is referenced by the MetaValueFactory which Teiid uses to unwrap properties
(11:07:59 PM) tejones: ips: So it seems like the jar should be added to the client jars since other plugins will likely do this as well?
(11:09:34 PM) ips: yeah, sounds like it

--- Additional comment from ian.springer@redhat.com on 2010-10-28 23:54:08 EDT ---

Fixed in master - commit f637fd4.

--- Additional comment from ian.springer@redhat.com on 2010-10-29 10:40:59 EDT ---

Fixed in release-3.0.0 - commit aa672c8.
Comment 1 Charles Crouch 2010-11-02 01:57:17 EDT
Needs testing by SOA-P team
Comment 2 Corey Welton 2011-01-05 09:45:41 EST
qa -> ldimaggi@redhat.com
Comment 3 Len DiMaggio 2011-01-05 13:48:41 EST
When are you seeing the error? When the plugin is installed? Or at runtime - while performing what actions?
Comment 4 Pavel Kralik 2011-01-11 13:42:32 EST
Tested installation on JON-2.4.1 and upgrade JON-2.4.0 to 2.4.1 (build #74) with discovered SOA-P 5.1.0.ER6 with EDS (Teiid).

No NoClassDefFoundError: org/jboss/reflect/spi/TypeInfo found in any log file.

Note You need to log in before you can comment on or make changes to this bug.