Bug 647844 - 'virsh list' will hang forever, rather than timing out and eventually completing
'virsh list' will hang forever, rather than timing out and eventually completing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 647845
  Show dependency treegraph
 
Reported: 2010-10-29 12:49 EDT by R P Herrold
Modified: 2011-12-01 12:07 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 531983
: 647845 (view as bug list)
Environment:
Last Closed: 2011-12-01 12:07:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2010-10-29 12:49:57 EDT
+++ This bug was initially created as a clone of Bug #531983 +++

Re-casting to focus on the (mis) behaviour of 'virsh list'


Description of problem:

'virsh list ' will hang forever 

context and reproducer are clear from the prior bug and are not repeated here

--- Additional comment from berrange@redhat.com on 2009-11-11 09:24:24 EST ---

30 seconds is appropriate for this. If it were any lower then it would cause unneccessary timeouts when the host is under high load and QEMU is slow to respond.  Having a completely dead QEMU is a unusual occurrence and not something we want to optimize for. Similarly we do not want to optimize for scenario of someone deliberately sending SIGSTOP to the process.

... later

The problem was that a hang on this one guest, would also cause a hang on all other libvirt guests which are still running normally.


RPH new content: from a libvirt POV, this may be solved from in a recent release , but 'virsh list' will still hang as I understand it

> What we solved in this bug, is that you can continue to request information about *other* guests, even when this one guest has hung.

> So the first 'virsh list' you run will *still* hang.

RPH proposed:

adding the timeout and error notification to 
   virsh list
is what is proposed, not some general roll-in of a 'one size fits all' timeout

--- Additional comment from berrange@redhat.com on 2010-10-29 11:59:18 EDT ---

The timeout described in comment #5 is relating to timeout while waiting on a lock in another part of the code, not the timing out of currently executing monitor commands. 

Regardless, this isn't the place for design & implementation discussions.

---------------

If filing a bug against the owning component is not the right place I am misunderstanding what you are saying

The misbehavour (the hanging without timeout of 'virsh list') is what is being reported here for resolution
Comment 1 Fedora Admin XMLRPC Client 2011-09-22 13:50:13 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2011-09-22 13:53:03 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2011-09-22 13:58:29 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-11-30 14:31:00 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-11-30 14:34:37 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2011-11-30 14:41:15 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2011-11-30 14:52:24 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Eric Blake 2011-12-01 12:07:28 EST
'virsh list' no longer hangs as of libvirt 0.9.2, thanks to the new virDomainGetState that allows querying a domain without any monitor command.

commit 46b95e64282b8eccf34b4636a93e89fb26f5a9ef
Author: Jiri Denemark <jdenemar@redhat.com>
Date:   Tue Apr 26 12:26:36 2011 +0200

    virDomainGetState public API implementation

Note You need to log in before you can comment on or make changes to this bug.