Bug 648362 - [ne_NE]Nepali Language Variant of Jha
Summary: [ne_NE]Nepali Language Variant of Jha
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lohit-devanagari-fonts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-01 05:54 UTC by Ujjwol
Modified: 2011-08-04 08:47 UTC (History)
5 users (show)

Fixed In Version: lohit-devanagari-fonts-2.4.3-8.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-06 20:03:17 UTC
Type: ---


Attachments (Terms of Use)
Nepali specific optional jha (5.81 KB, image/png)
2010-11-01 05:54 UTC, Ujjwol
no flags Details
Optional Nepali Specific Jha (304.86 KB, image/jpeg)
2010-11-01 11:01 UTC, Ujjwol
no flags Details

Description Ujjwol 2010-11-01 05:54:18 UTC
Created attachment 456794 [details]
Nepali specific optional jha

Description of problem:
Nepali language in most cases uses the devangari northern variant jha but sometimes a specific Nepali variant of jha is also used. Please support for that. I have attached one rough/okay glyph of that.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Remember this is used in some cases only, in normal case devanagari northern variant is used.

Comment 1 Pravin Satpute 2010-11-01 06:56:32 UTC
can you give me some references for this?

Comment 2 Ujjwol 2010-11-01 07:02:08 UTC
There are no online references, it is used in many books in Nepali. So, what should I do ? Will any other people supporting this will work ?

Comment 3 Pravin Satpute 2010-11-01 07:58:47 UTC
no props, 
will be nice if you can put scanned image or photographs showing these exceptions required for Nepali.

I can surely add these with proper reference, so if anyone in nepali locale will get this shape by default  for jha  झ U+091D

Comment 4 Ujjwol 2010-11-01 09:00:01 UTC
Ok I will try to put the scanned image and inform you. But this jha is not be used by default for jha, it is an for a variant of jha.Ok I will try to put the scanned image and inform you. But this jha is not be used by default for jha, it is an for a variant of jha.

Comment 5 Ujjwol 2010-11-01 09:12:10 UTC
As I have seen in some font I don't remember, open type feature allows use to have different glyph as variants, so I thought the font developer would know this. and filed a bug. For nepali locale the default font should be northern variant of झ. I forgot to file bug on that. Here is the bug.https://bugzilla.redhat.com/show_bug.cgi?id=648423

Not to get confused.
For Nepali Locale:
Bha like Jha should be default.
And other jha should be a optional variant.

Comment 6 Pravin Satpute 2010-11-01 10:23:08 UTC
check madan font and update this bug with proper information, if madan is correct we can follow that

Comment 7 Ujjwol 2010-11-01 11:01:19 UTC
Yes! Madan uses this type of glyph by default. It should not happen. Lohit Devanagari should use this glyph as variant of the jha but not by default. The default jha should be the glyph from his https://bugzilla.redhat.com/show_bug.cgi?id=648423

But, this also needs to be added. As it an important variant. I have attached an reference form this book:
भानुभक्तको रामायण
साझा प्रकाशन
A most popular literary work in Nepali language. It is ramayana in Nepali.

Comment 8 Ujjwol 2010-11-01 11:01:58 UTC
Created attachment 456845 [details]
Optional Nepali Specific Jha

Comment 9 Pravin Satpute 2010-11-02 04:25:22 UTC
madan font is specific for Nepali, so it is using Nepali shapes by default.
But year in lohit we need to handle this in different way

Comment 10 Ujjwol 2010-11-02 04:32:01 UTC
Madan is a font designed for print, it doesn't looks great for in screen. Lohit is designed for screen. And even the glyph madan uses is not the most popular one for jha.

Comment 11 Nicolas Mailhot 2010-11-02 13:32:29 UTC
(In reply to comment #9)
> madan font is specific for Nepali, so it is using Nepali shapes by default.
> But year in lohit we need to handle this in different way

If the problem can be solved via locl magic there is no reason not to fix mandan too

Comment 12 Pravin Satpute 2010-11-03 10:53:36 UTC
yes, i do agree
in next release of lohit devanagari i am thinking to add locl feature, once tested we can request madan upstream for same

Comment 13 Pravin Satpute 2010-11-25 08:59:00 UTC
i am little bit confused between this bug and bug https://bugzilla.redhat.com/show_bug.cgi?id=648423

what exactly we suppose to do?

1) Add झ variant for Nepali as show in reference image attached on https://bugzilla.redhat.com/attachment.cgi?id=456843

Comment 14 Fedora Update System 2010-11-26 10:09:13 UTC
lohit-devanagari-fonts-2.4.3-8.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/lohit-devanagari-fonts-2.4.3-8.fc14

Comment 15 Fedora Update System 2010-11-26 21:06:27 UTC
lohit-devanagari-fonts-2.4.3-8.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lohit-devanagari-fonts'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/lohit-devanagari-fonts-2.4.3-8.fc14

Comment 16 Fedora Update System 2010-12-06 20:02:53 UTC
lohit-devanagari-fonts-2.4.3-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Shriramana Sharma 2011-08-04 08:47:07 UTC
(In reply to comment #8)
> Created attachment 456845 [details]
> Optional Nepali Specific Jha

The additional JHA variant which looks like BHA with tail has been added. 

It is merely the Northern variant of JHA as seen in the Uttara font: http://sanskritweb.net/cakram/chandas.htm and it has a well-defined half-form https://bugzilla.redhat.com/attachment.cgi?id=456829

So what is the half-form of *this* additional Nepali variant of JHA: i.e. https://bugzilla.redhat.com/attachment.cgi?id=456845 ?


Note You need to log in before you can comment on or make changes to this bug.