Bug 648850 - Don't crash on systems that don't support XF86VM or XRANDR gamma fade
Summary: Don't crash on systems that don't support XF86VM or XRANDR gamma fade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-screensaver
Version: 6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 645519 GSS_6_2_PROPOSED 697582 648869
TreeView+ depends on / blocked
 
Reported: 2010-11-02 10:04 UTC by ritz
Modified: 2011-12-06 16:28 UTC (History)
2 users (show)

Fixed In Version: gnome-screensaver-2.28.3-11.el6
Doc Type: Bug Fix
Doc Text:
When the user locked the screen and the X Window System did not support the X Resize, Rotate (XRandR) or XF86VM gamma fade extensions, then the gnome-screensaver utility terminated with a segmentation fault. Now, additional checks are made before calling the fade_setup() function, which fixes the problem.
Clone Of:
Environment:
Last Closed: 2011-12-06 16:28:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1652 normal SHIPPED_LIVE gnome-screensaver bug fix and enhancement update 2011-12-06 00:50:26 UTC

Description ritz 2010-11-02 10:04:12 UTC
Description of problem:
Don't crash on systems that don't support XF86VM or XRANDR gamma fade

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
https://bugzilla.gnome.org/show_bug.cgi?id=618925

Patch - http://git.gnome.org/browse/gnome-screensaver/commit/?id=904e72f40f5a02935d5dbd5392d9a9483786a2d1

Comment 2 RHEL Program Management 2011-01-07 16:04:07 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 6 Ray Strode [halfline] 2011-06-20 15:05:22 UTC
devack

Comment 10 Eliska Slobodova 2011-08-12 09:39:19 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When the user locked the screen and the X Window System did not support the X Resize, Rotate (XRandR) or XF86VM gamma fade extensions, then the gnome-screensaver utility terminated with a segmentation fault. Now, additional checks are made before calling the fade_setup() function, which fixes the problem.

Comment 12 errata-xmlrpc 2011-12-06 16:28:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1652.html


Note You need to log in before you can comment on or make changes to this bug.