Bug 64886 - scanner stoped working after rh7.2==>rh7.3 upgrade
Summary: scanner stoped working after rh7.2==>rh7.3 upgrade
Status: CLOSED DUPLICATE of bug 64964
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sane (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-13 21:36 UTC by Need Real Name
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-13 21:37:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
long directory listing of /usr/lib/sane (3.54 KB, text/plain)
2002-05-13 21:37 UTC, Need Real Name
no flags Details

Description Need Real Name 2002-05-13 21:36:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
After upgrading to 7.3, the scanner stopped working.  sane-find-scanner was able
to find the vendor and product number of the scanner but could not find the
scanner's name.  The scanner is an HP5200C.  scanimage -L reported that there
was no scanner.  /var/log/messages had a ton of "usb_control/bulk_msg: timeout"
messages.

After hunting around a bit I found /usr/lib/sane and noticed that there were
very few symbolic links from the generic libraries to the specific libraries.  I
added "ln -s libsane-hp.so.1.0.7 libsane-hp.so.1" and now everything works fine.

I'm not sure why the upgrade didn't add the appropriate symbolic links.

Attached is a complete list of the /usr/lib/sane directory.  Only the
libsane-hp.so.1 link was added manually.

Note: the computer that had this install problem had originally been installed
with rh6.1 and subsequently upgraded to 6.2, 7.0, 7.1, 7.2, and 7.3

Comment 1 Need Real Name 2002-05-13 21:37:30 UTC
Created attachment 57164 [details]
long directory listing of /usr/lib/sane

Comment 2 Tim Waugh 2002-05-15 10:57:50 UTC

*** This bug has been marked as a duplicate of 64964 ***


Note You need to log in before you can comment on or make changes to this bug.