Bug 64892 - Anaconda crashes when selecting "none none" for mouse type
Summary: Anaconda crashes when selecting "none none" for mouse type
Status: CLOSED DUPLICATE of bug 64588
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-13 22:34 UTC by Matt Perry
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-13 22:35:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump file from anaconda (30.46 KB, text/plain)
2002-05-13 22:35 UTC, Matt Perry
no flags Details

Description Matt Perry 2002-05-13 22:34:31 UTC
When going through the installer with all the defaults and you reach the mouse 
configuration screen, choose "none none" at the bottom.  When you click on 
Next, Anaconda crashes with the following error:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 130, in __call__
    ret = apply(self.func, a)
  File "/usr/lib/anaconda/gui.py", line 413, in nextClicked
    rc = self.currentWindow.getNext ()
  File "/usr/lib/anaconda/iw/mouse_gui.py", line 96, in getNext
    self.mouse.setXProtocol ()
  File "/usr/lib/anaconda/mouse.py", line 209, in setXProtocol
    curmouse[0] = "/dev/" + self.device
TypeError: illegal argument type for built-in operation

Comment 1 Matt Perry 2002-05-13 22:35:29 UTC
Created attachment 57184 [details]
Dump file from anaconda

Comment 2 Michael Fulbright 2002-05-14 20:51:46 UTC

*** This bug has been marked as a duplicate of 64588 ***

Comment 3 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated


Note You need to log in before you can comment on or make changes to this bug.