Bug 64912 - French latin9 keybord layout support
Summary: French latin9 keybord layout support
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
: 79471 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-14 12:51 UTC by Nicolas Mailhot
Modified: 2007-04-18 16:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-20 07:10:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example spec just for this layout (1.26 KB, patch)
2002-05-14 16:01 UTC, Nicolas Mailhot
no flags Details | Diff

Description Nicolas Mailhot 2002-05-14 12:51:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:

The french keyboard layout defined in Red Hat Linux is very bad.
Please consider bundling the official francophones-howto (aka french-howto)
layout instead

Steps to Reproduce:

Some examples of what the current fr layout does badly : the very common "oe"
french caracter is impossible to type easyly, french quotes are mapped on q and
w but q and w are not next to each other in azerty keyboards, etc

Additional info:

See the official francophones-howto layout at
http://www.ibiblio.org/guylhem/programmes/EURO-2.tgz

You can either replase the fr layout or add a new fr-latin9 layout

I fairly sure mdk already bundles it

Comment 1 Mike A. Harris 2002-05-14 13:21:34 UTC
Requests like this should generally be made to XFree86.org directly. If
every distro has to manually add stuff like this it creates a massive amount
of work duplication.  If XFree86.org includes it in an official XFree86
release however, then everyone gets it all at once.  Please make a request
to XFree86.org by sending an email fixes@xfree86.org with the URL and/or
file attached, so they can integrate it directly.  Then Red Hat, as well as
all other vendors can pick up the enhancement simultaneously.

Thanks.

Comment 2 Nicolas Mailhot 2002-05-14 14:00:17 UTC
Well this layout has been around for quite a long time, is well maintained by a
very well-known and reliable person, the only reason I can think it's still not
in X is that the very good howto that points to it is written in french.

(btw the same layout is available for linux console, the only thing to remember
is  to remove the charset line in the .map to use it on rawhide)

Comment 3 Nicolas Mailhot 2002-05-14 16:01:51 UTC
Created attachment 57284 [details]
Example spec just for this layout

Comment 4 Nicolas Mailhot 2002-07-11 08:04:50 UTC
Note that the console version of this layout has been added to kbd as fr-latin0

Comment 5 Mike A. Harris 2002-08-08 09:27:27 UTC
Again, I must ask that you please submit this keyboard layout to
XFree86.org for proper inclusion in upstream XFree86.  If I see
that it has been commited to CVS, then I can consider applying it
to our builds.

The more Red Hat patches up X, the more we have to maintain it that
way for a longer time.  If XFree86 has the patches included in CVS,
we at least know any patches are temporary.

Closing as WONTFIX for now.  Feel free to reopen this once the patches
are included in XFree86 CVS.

Comment 6 Mike A. Harris 2002-12-20 07:00:39 UTC
*** Bug 79471 has been marked as a duplicate of this bug. ***

Comment 7 Mike A. Harris 2002-12-20 07:10:44 UTC
Support for this went into XFree86 CVS today, and will be in my next
XFree86 CVS update in rawhide.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.