Bug 79471 - Can not load french keyboard layout anymore
Can not load french keyboard layout anymore
Status: CLOSED DUPLICATE of bug 64912
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-11 18:38 EST by Nicolas Mailhot
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SRPM of fr-latin9 X layout (163.79 KB, application/octet-stream)
2002-12-11 18:40 EST, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2002-12-11 18:38:41 EST
The default XFree86 french layout has been too broken to use for years (there
are lots of small mistakes, lack of euro support, alternate key values that make
sense on a qwerty keyboard but not an azerty one and so on). Seems at some time
it was submitted by someone who actually used it and them morphed in a useless
blob by qwerty-users.

The tldp francophones-howto (aka french-howto) has therefore distributed for a
very long time its own "official" keyboard layout. And I got so tired of
installing by hand on each new RH install/waiting for it to get merged I even
packaged it in an rpm (guess XFree86 dropped the layout when it was submitted by
its author and i18n-friendly distros are all too happy to let us-centric ones
ship broken setups to push it into XFree86 proper).

This layout was even merged in kbd lately.

Anyway the point is this file worked for lots of successive RH versions but
somehow broke on RawHide XFree86 recently. This is *very* annoying. Not only no
one wants to merge it in the US but normal load do not work anymore !

setxkbmap prints an informative (yes I mucked rules/xfree86, not that it changed
anything)

Setting verbose level to 10
locale is C
Warning! Multiple definitions of keyboard layout
         Using command line, ignoring X server
Applied rules from xfree86:
model:      pc105
layout:     fr-latin9
Trying to build keymap using the following components:
keycodes:   xfree86+aliases(azerty)
types:      complete
compat:     complete
symbols:    pc/pc(pc105)+pc/fr-latin9
geometry:   pc(pc105)
Error loading new keyboard description

With in the X logs :

Error loading keymap /usr/X11R6/lib/X11/xkb/compiled/server-0.xkm

I suspect setxkbmap can not load non-precompiled layouts anymore

(note the right fix would be to merge the fr-latin9 layout, it's not like
XFree86 maintainers have shown any intention to straighten-up their french
layout in the past years - and the fr-latin9 layout author Guylhem Aznar is not
exactly a rookie either)
Comment 1 Nicolas Mailhot 2002-12-11 18:40:02 EST
Created attachment 88488 [details]
SRPM of fr-latin9 X layout
Comment 2 Mike A. Harris 2002-12-12 03:36:06 EST
>The tldp francophones-howto (aka french-howto) has therefore distributed for a
>very long time its own "official" keyboard layout. And I got so tired of
>installing by hand on each new RH install/waiting for it to get merged I even
>packaged it in an rpm (guess XFree86 dropped the layout when it was submitted by
>its author and i18n-friendly distros are all too happy to let us-centric ones
>ship broken setups to push it into XFree86 proper).

The xkb files that are shipped in Red Hat Linux, are the ones supplied
by XFree86.org.  If those files are broken, it is because they people
who use the particular keyboard mapping and may or may not have fixed
it, have not submitted bug fixes to XFree86.org for their keyboard
layout.

I will not accept new keyboard layouts for submission into Red Hat Linux
at all period.  If I were to do that, then I am stuck maintaining that
layout indefinitely.  Any keyboard layout submissions absolutely _must_
be submitted to fixes@xfree86.org, as this is an XFree86.org problem
and not one central to Red Hat Linux.  Then, and only then, will such
keyboard layouts be accepted into Red Hat Linux.

If XFree86.org refuses this layout, then it is not something that Red Hat
is willing to ship either.  If there are problems with the map that need
to be fixed before it is applied to XFree86.org sources, then the author
of the layout, or the body of people supporting the layout need to get
together on xpert@xfree86.org and discuss whatever problems there are
with the XFree86 developers, and fix them until XFree86.org accepts the
layout into the official XFree86 distribution.

Sorry, but we simply do not have the engineering manpower to
continuously patch in people's various keyboard mapping enhancements,
and then fix and repatch those patches indefinitely as the official
XFree86 files upstream change over time.  This is something that needs
to be taken care of between the original author(s) and XFree86.org
directly.
Comment 3 Mike A. Harris 2002-12-20 02:00:37 EST

*** This bug has been marked as a duplicate of 64912 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:50:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.