This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 649230 - [si] last input character is committed late in wijesekara input method
[si] last input character is committed late in wijesekara input method
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-m17n (Show other bugs)
14
Unspecified Linux
medium Severity high
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
: i18n, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-03 05:43 EDT by Danishka Navin
Modified: 2010-11-15 11:47 EST (History)
10 users (show)

See Also:
Fixed In Version: ibus-m17n-1.3.1-6.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-08 17:34:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
MDEBUG_INPUT log from m17n-edit (30.54 KB, text/plain)
2010-11-04 02:46 EDT, Daiki Ueno
no flags Details
MDEBUG_INPUT log from ibus-m17n (30.70 KB, text/plain)
2010-11-04 02:47 EDT, Daiki Ueno
no flags Details

  None (edit)
Description Danishka Navin 2010-11-03 05:43:06 EDT
Description of problem:


in each work last character wont appear correctly till we press space or any other key

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. select wijesekara input method 
2. type "අම්මා"  key sequence is 'wuaud'
3. අ should appear once you press w 


  
Actual results:

need to wait till next character to see the most last character entered 

Expected results:

characters should appear once we type required keys..

Additional info:

'ම' can type using 'u'
but we have to pre 'uu' or any key after 'u'
Comment 1 A S Alam 2010-11-03 05:47:48 EDT
m17n-db-1.6.1-3.fc14.noarch
Comment 2 Harshula Jayasuriya 2010-11-03 09:26:15 EDT
Sounds a lot like Bug 614867, which should be fixed in F14.

To determine if it is an IBus bug or m17n bug. Run m17n-edit (LANG=c m17n-edit) and see if you can reproduce it. If you can't, then it is an IBus bug. m17n-edit is in the m17n-lib-tools RPM.
Comment 3 Jens Petersen 2010-11-03 21:36:26 EDT
Easily reproduced on Live media - F13 seems ok but not F14.

I guess it is not m17n-db so moving to ibus-m17n while we triage.
Comment 4 Daiki Ueno 2010-11-03 22:35:10 EDT
Probably the same cause as #639253, which I postponed the fix to the next release since it requires update of ibus core.

Anyway here is a koji scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2575748
Comment 5 Daiki Ueno 2010-11-04 02:00:07 EDT
(Sorry, my comment 4 is pointless, please ignore)

I did some more tests and noticed that:

- This bug occurs only when the user "delete" a character in preedit.  I can't reproduce it on the first time I input "wuaud", but if I type it again after 5 Backspaces, the problem is shown up.

- This can be reproduced even with ibus-m17n 1.3.0 (which is the base upstream version bundled in F-13) manually compiled from source.

- If I enable surrounding-text, the problem seems to go away.

I suspect there is a bug in preedit update code of the latest ibus.

Anyway the workaround is to enable surrounding-text from the setup dialog or adding the following lines to ~/.m17n.d/config.mic manually:

((input-method si wijesekera)
 (variable
  (use-surrounding-text nil 1)))
Comment 6 Harshula Jayasuriya 2010-11-04 02:14:33 EDT
Hi Daiki, Can you reproduce in m17n-edit?
Comment 7 Daiki Ueno 2010-11-04 02:43:21 EDT
(In reply to comment #6)
> Hi Daiki, Can you reproduce in m17n-edit?

No, I can't. I tried to compare m17n-lib debugging output from both m17n-edit (correct behavior) and ibus-m17n (buggy behavior), when I typed "wuaud", BS 5 times, and type "wuaud" again, with MDEBUG_INPUT=1.  However, the logs are almost identical.

Anyway I'm attaching them.
Comment 8 Daiki Ueno 2010-11-04 02:46:33 EDT
Created attachment 457672 [details]
MDEBUG_INPUT log from m17n-edit
Comment 9 Daiki Ueno 2010-11-04 02:47:07 EDT
Created attachment 457673 [details]
MDEBUG_INPUT log from ibus-m17n
Comment 10 Daiki Ueno 2010-11-04 22:34:00 EDT
(In reply to comment #9)
> Created attachment 457673 [details]
> MDEBUG_INPUT log from ibus-m17n

Got it - there is an "[IM] reset" line and it indicates that ibus-m17n engine instance is dissociated from minput context, and once switched to such a situation ibus-m17n cannot continue working with preedit correctly.  Never tested but I guess that the old si-wijesekera.mim included in F-13 does not signal reset.

Fortunately this is already addressed by the upstream change:
http://codereview.appspot.com/2260041

I'm closing this with a new package including the fix.
Comment 11 Fedora Update System 2010-11-04 23:09:52 EDT
ibus-m17n-1.3.1-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ibus-m17n-1.3.1-6.fc14
Comment 12 Danishka Navin 2010-11-04 23:34:51 EDT
Anandawardana,

Could you please install following package and check if you can reproduce the issue?

http://kojipkgs.fedoraproject.org/packages/ibus-m17n/1.3.1/6.fc14/i686/ibus-m17n-1.3.1-6.fc14.i686.rpm
Comment 13 Harshula Jayasuriya 2010-11-04 23:48:18 EDT
Hi,

I was unable to reproduce this on my system because I had m17n-db 1.6.2 version of Wijesekera and Renganathan installed.

Download the latest version from:
http://cvs.m17n.org/viewcvs/m17n/m17n-db/MIM/si-wijesekera.mim?view=co
http://cvs.m17n.org/viewcvs/m17n/m17n-db/MIM/ta-lk-renganathan.mim?view=co

The respective patches that fix this are:
http://cvs.m17n.org/viewcvs/m17n/m17n-db/MIM/si-wijesekera.mim?r1=1.9&r2=1.10
http://cvs.m17n.org/viewcvs/m17n/m17n-db/MIM/ta-lk-renganathan.mim?r1=1.2&r2=1.3

F14 has m17n-db 1.6.1 and should be updated to m17n-db 1.6.2.

Regards,
Harshula
Comment 14 Danishka Navin 2010-11-04 23:52:30 EDT
Daiki,
its working. added comment on bodhi as well.

Good job!
Comment 15 A S Alam 2010-11-05 01:00:18 EDT
This issue seems fixed, but I am facing another problem, while using this
if I press d or e or like that character, then some time (randomly), it _stick_ to cursor and DEL and BKSP is not working to remove that, just press ALT+TAB and back to same application (where you are working), then it automatically went.
Anybody able to reproduce???
Comment 16 Harshula Jayasuriya 2010-11-05 01:10:08 EDT
Alam, are you using both ibus-m17n-1.3.1-6.fc14 and si-wijesekera.mim from m17n-db 1.6.2 or from CVS?
Comment 17 A S Alam 2010-11-05 04:55:17 EDT
(In reply to comment #16)
> Alam, are you using both ibus-m17n-1.3.1-6.fc14 and si-wijesekera.mim from
> m17n-db 1.6.2 or from CVS?

I used RPM, which has m17n-db-1.6.1 only in F14
Comment 18 Harshula Jayasuriya 2010-11-05 05:55:08 EDT
(In reply to comment #17)
> I used RPM, which has m17n-db-1.6.1 only in F14

Grab the latest si-wijesekera.mim and see if you can reproduce the problem you are seeing:
http://cvs.m17n.org/viewcvs/m17n/m17n-db/MIM/si-wijesekera.mim?view=co

Daiki confirmed that the original reported bug is also fixed by the latest si-wijesekera.mim in CVS.
Comment 19 Fedora Update System 2010-11-05 18:52:04 EDT
ibus-m17n-1.3.1-6.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus-m17n'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/ibus-m17n-1.3.1-6.fc14
Comment 20 A S Alam 2010-11-07 23:32:25 EST
(In reply to comment #18)
> (In reply to comment #17)
> > I used RPM, which has m17n-db-1.6.1 only in F14
> 
> Grab the latest si-wijesekera.mim and see if you can reproduce the problem you
> are seeing:
> http://cvs.m17n.org/viewcvs/m17n/m17n-db/MIM/si-wijesekera.mim?view=co
> 
> Daiki confirmed that the original reported bug is also fixed by the latest
> si-wijesekera.mim in CVS.

thanks it is working for above file.
Comment 21 Harshula Jayasuriya 2010-11-07 23:40:20 EST
Alam, maybe open another Bug against m17n-db 1.6.1 for the problem that you found?
Comment 22 A S Alam 2010-11-08 00:07:12 EST
ok, #650802
Comment 23 Fedora Update System 2010-11-08 17:34:14 EST
ibus-m17n-1.3.1-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Danishka Navin 2010-11-15 11:47:48 EST
tested! its fixed

Note You need to log in before you can comment on or make changes to this bug.