Bug 649319 - cannot upload binary config file
cannot upload binary config file
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management (Show other bugs)
540
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Pavel Novotny
: Regression
: 664680 (view as bug list)
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2010-11-03 10:30 EDT by Tomas Lestach
Modified: 2011-01-04 12:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Although RHN Satellite allows a user to upload binary configuration files, an error in a previous update caused this feature not to work. With this update, this error has been fixed, and uploading binary files no longer fails.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-16 10:45:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2010-11-03 10:30:19 EDT
Description of problem:


Version-Release number of selected component (if applicable):
sat540

How reproducible:
always

Steps to Reproduce:
1. Create a config channel
2. Navigate to - Add Files - Upload File
3. Select binary as file type and select as "File to upload" select small binary file 
4. Set any Filename/Path and submit
  
Actual results:
no file was added to the config channel
WebUI shows following error messages:
Macro end tag is required.
Macro start tag is required.

Expected results:
Successful file upload

Additional info: looks like regression against 530
Comment 1 Tomas Lestach 2010-11-03 10:33:25 EDT
One more related issue:
if uploading a text file and then trying to set the file mode to "binary", getting the same result as described in #Description.
Comment 2 Tomas Lestach 2010-11-03 14:24:38 EDT
fixed both issues

spacewalk.git: 1f34d41208008af469b75e3a9caa21c53ae59b32
Comment 5 Pavel Novotny 2010-12-07 10:22:26 EST
Verified.

# rpm -q spacewalk-java
spacewalk-java-1.2.39-32.el5sat

Successfully uploaded small binary file according to steps in comment #0.
Also tried case mentioned in comment #1 when I uploaded regular text file (with type "Text File") and then changed it to "Binary File". Passed without problems.
Comment 7 errata-xmlrpc 2010-12-16 10:45:15 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0991.html
Comment 8 Jaromir Hradilek 2010-12-16 11:34:58 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Although RHN Satellite allows a user to upload binary configuration files, an error in a previous update caused this feature not to work. With this update, this error has been fixed, and uploading binary files no longer fails.
Comment 9 Tomas Lestach 2011-01-04 12:48:59 EST
*** Bug 664680 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.