Bug 64932 - zshall man page is (still) broken
zshall man page is (still) broken
Status: CLOSED DUPLICATE of bug 19555
Product: Red Hat Linux
Classification: Retired
Component: groff (Show other bugs)
7.3
All Linux
medium Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-14 15:24 EDT by Mathieu Chouquet-Stringer
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-14 16:50:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mathieu Chouquet-Stringer 2002-05-14 15:24:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.1 (X11; Linux i686; U;) Gecko/20020417

Description of problem:
Since the switch to gzipped man pages, the zshall man page is broken.
Simply because it tries to open man1/zshmisc.1 for example which is really
zshmisc.1.gz. The result is that the man page is incomplete.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. man zshall

Actual Results:  The best way to see the result is to redirect man's standard
output:
man zshall > /dev/null
Here is the result:
<standard input>:472: realpath on `man1/zshmisc.1' failed: No such file or directory
<standard input>:473: realpath on `man1/zshexpn.1' failed: No such file or directory
<standard input>:474: realpath on `man1/zshparam.1' failed: No such file or
directory
<standard input>:475: realpath on `man1/zshoptions.1' failed: No such file or
directory
<standard input>:476: realpath on `man1/zshbuiltins.1' failed: No such file or
directory
<standard input>:477: realpath on `man1/zshzle.1' failed: No such file or directory
<standard input>:478: realpath on `man1/zshcompwid.1' failed: No such file or
directory
<standard input>:479: realpath on `man1/zshcompsys.1' failed: No such file or
directory
<standard input>:480: realpath on `man1/zshcompctl.1' failed: No such file or
directory
<standard input>:481: realpath on `man1/zshmodules.1' failed: No such file or
directory
<standard input>:482: realpath on `man1/zshzftpsys.1' failed: No such file or
directory
<standard input>:483: realpath on `man1/zshcontrib.1' failed: No such file or
directory


Expected Results:  I would have expected to get the complete man page.

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-05-14 16:50:40 EDT
Not a zsh bug, an old, known, unfixed groff bug.
Comment 2 Trond Eivind Glomsrxd 2002-05-14 16:52:16 EDT

*** This bug has been marked as a duplicate of 19555 ***

Note You need to log in before you can comment on or make changes to this bug.