Bug 649526 - xorg crashes with kde and xinerama with nvidia
Summary: xorg crashes with kde and xinerama with nvidia
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 14
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 649524 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-03 21:43 UTC by phil.hopkins
Modified: 2018-04-11 15:24 UTC (History)
17 users (show)

Fixed In Version: xorg-x11-server-1.9.1-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-26 01:04:26 UTC
Type: ---


Attachments (Terms of Use)
xorg log file (21.33 KB, text/plain)
2010-11-03 21:43 UTC, phil.hopkins
no flags Details
xorg conf file (3.13 KB, text/plain)
2010-11-03 21:45 UTC, phil.hopkins
no flags Details
smolt profile (5.71 KB, text/plain)
2010-11-03 21:46 UTC, phil.hopkins
no flags Details
xsession errors file (17.47 KB, text/plain)
2010-11-08 19:27 UTC, phil.hopkins
no flags Details

Description phil.hopkins 2010-11-03 21:43:52 UTC
Created attachment 457593 [details]
xorg log file

Description of problem:
xorg crashes with kde and xinerama with nvidia upon login. KDE gets to the point of just starting to display background images and crashes. Login is successful with gnome. I have two nvidia graphics cards (GeForce 8400 GS) and 3 screens.


Version-Release number of selected component (if applicable): Fedora 14 with updates. kdebase-4.5.2-2.fc14.x86_64, 


How reproducible: Happens every time


Steps to Reproduce:
1.gdm login select user
2.enter password
3.wait until crash!!

Again I can successfuly log into a Gnome session 
  
Actual results:


Expected results:


Additional info:

Comment 1 phil.hopkins 2010-11-03 21:45:02 UTC
Created attachment 457594 [details]
xorg conf file

Comment 2 phil.hopkins 2010-11-03 21:46:01 UTC
Created attachment 457595 [details]
smolt profile

Comment 3 phil.hopkins 2010-11-03 21:46:53 UTC
Please let me know if you need any additional information

Comment 4 Kevin Kofler 2010-11-03 22:08:52 UTC
I am sorry, but all your evidence points to a bug in the proprietary nvidia driver. Unfortunately, we have no way to fix any issues in that driver. Please report your crash to NVidia.

Comment 5 Rex Dieter 2010-11-04 13:19:06 UTC
Let's not be *too* hasty here.  

Some relevant helpful logs would be ~/.xsession-errors and /var/log/Xorg.0.log

Comment 6 Rex Dieter 2010-11-04 13:30:24 UTC
*** Bug 649524 has been marked as a duplicate of this bug. ***

Comment 7 Kevin Kofler 2010-11-04 15:13:09 UTC
> /var/log/Xorg.0.log

That file is already attached, isn't it? (attachment 457593 [details])


In fact I looked at the log:

[  1255.195] (II) LoadModule: "nvidia"
[  1255.196] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[  1255.196] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1255.196] 	compiled for 4.0.2, module version = 1.0.0
[  1255.196] 	Module class: X.Org Video Driver
[  1255.196] (II) NVIDIA dlloader X Driver  260.19.12  Fri Oct  8 11:19:20 PDT 2010
[  1255.196] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs

This confirms that the proprietary driver is being loaded. And further down:

[  1272.081] 
Backtrace:
[  1272.081] 0: /usr/bin/Xorg (xorg_backtrace+0x2d) [0x483065]
[  1272.081] 1: /usr/bin/Xorg (0x400000+0x52cb2) [0x452cb2]
[  1272.081] 2: /lib64/libc.so.6 (0x7f5a25547000+0x340e0) [0x7f5a2557b0e0]
[  1272.081] 3: /usr/bin/Xorg (0x400000+0x8ca05) [0x48ca05]
[  1272.081] 4: /usr/bin/Xorg (0x400000+0x2b02e) [0x42b02e]
[  1272.081] 5: /usr/bin/Xorg (0x400000+0x215da) [0x4215da]
[  1272.081] 6: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f5a25565e7d]
[  1272.081] 7: /usr/bin/Xorg (0x400000+0x210a9) [0x4210a9]
[  1272.081] Segmentation fault at address 0x4
[  1272.081] 
Fatal server error:
[  1272.081] Caught signal 11 (Segmentation fault). Server aborting

This shows it's the X process itself crashing, not anything in KDE. So the bug is either in the X.Org X11 server or in one of the drivers it loads (usually the video driver). Speaking from experience, the latter is much more likely. And we cannot debug the proprietary driver because we do not have its source code.

We can try reassigning the bug to xorg-x11-server, but I don't think they'll be able to figure out what's going on, due to the above. (Or can you reproduce the issue with one of the drivers in Fedora, e.g. nouveau?)

Comment 8 phil.hopkins 2010-11-08 19:20:42 UTC
I am certain that this isn't a problem with the nvidia driver. Take a look at bug 624297. There is a fix for the supposed nvidia symbol issues, even implementing then the crash occurs. I could use this xorg.conf file for Fedora 13 and everything works. I noticed that the lixXinerama was brought over from Fedora 13 so I recompiled them for Fedora 14 and I get the same crash.

It is repeatable and if I comment out the Xinerama from the xorg.conf file KDE starts but with two  xsessions. I can launch xterm on the second xsession with xterm --display :0.1


Phil

Comment 9 phil.hopkins 2010-11-08 19:23:35 UTC
By the way I cannot get the nouveau driver to work with my graphics card. I best I have been able to achieve is to get an xsession running on one screen but the mouse had an invisible cursor which needless to say made life very difficult.

I am also getting core dumps when the xorg-x11-server crashes.

Phil

Comment 10 phil.hopkins 2010-11-08 19:27:39 UTC
Created attachment 458861 [details]
xsession errors file

Here is the xsession errors file from the latest crash on the xserver

Comment 11 Kevin Kofler 2010-11-09 05:52:39 UTC
> I am certain that this isn't a problem with the nvidia driver. Take a look at
> bug 624297.

That bug is about programs which automatically set up xorg.conf for you. I strongly doubt it has anything to do with your issue, and in fact, as you say:

> There is a fix for the supposed nvidia symbol issues, even implementing then
> the crash occurs.

That kinda shows it's not related to your bug, doesn't it? :-)


In any case, it's not a KDE issue, so I'm reassigning this to xorg-x11-server and letting our X.Org X11 folks decide whether they can (and want to) do anything about this or whether they'll just close it as I originally did. (There's definitely nothing that can be done about this in kde*.)

Comment 12 phil.hopkins 2010-11-09 13:25:50 UTC
Keven, 

I agree it's not KDE, its a X.Org X11-server issue with Xinerama, that didn't exist in Fedora 13. Gnome can merge two xwindows sessions and KDE cannot. KDE requires xinerama and that is the issue. 

Has the X.Org server in Fedora 14 been complied with the xinerama options?

Phil

Comment 13 Matěj Cepl 2010-11-09 14:49:46 UTC
(In reply to comment #12)
> I agree it's not KDE, its a X.Org X11-server issue with Xinerama, that didn't
> exist in Fedora 13. Gnome can merge two xwindows sessions and KDE cannot. KDE
> requires xinerama and that is the issue. 

KDE hasn't required Xinerama for ages, it has been XRandR based even before Gnome was.

> Has the X.Org server in Fedora 14 been complied with the xinerama options?

However, more importantly this is binary-only nvidia issue. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

The open source 'nouveau' driver (in package xorg-x11-drv-nouveau) is the recommended alternative for users of Nvidia graphic chips.  It is used by default in Fedora 11 and later if you remove any customizations that explicitly set the video driver.  The older "nv" driver may be needed in some cases.  It is also available in older Fedora releases.  Install the packages xorg-x11-drv-nouveau or xorg-x11-drv-nv and override the X server's default choice if necessary.  See https://fedoraproject.org/wiki/Features/NouveauAsDefault for more information.

If you used a non-packaged version of the driver from the Nvidia website please clean your system from additional libraries and software it installed. For users who are experiencing problems installing, configuring, or using the unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides indirect customer support via an online web based support forum.  Nvidia monitors these web forums for commonly reported problems and passes them on to Nvidia engineers for investigation.  Once they've isolated a particular problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

	http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have experienced the particular problem may be able to assist.  If there is a real bug occuring, Nvidia will be able to determine this, and will likely resolve the issue in a future driver update for the operating system releases that they officially support.

While we does not support the proprietary nvidia driver, users requiring technical support may also find the various X.Org, XFree86, and Red Hat/Fedora mailing lists helpful in finding assistance:

X.Org mailing lists:
	http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
	http://www.xfree86.org/sos/lists.html

Red Hat/Fedora mailing lists:
	https://listman.redhat.com/mailman/listinfo

Comment 14 phil.hopkins 2010-11-09 15:16:53 UTC
I really hate these type of knee jerk responses. This is NOT a NVIDIA problem. 

If one is needing to use 3 monitors (multiple gpu's), xrandr is not an option. Currently the only solution is to use Xinerama. I realize that Ximerama is not being developed further but until multi-gpu support is added to xrandr (if it ever gets added) the only solution is Xinerama. 

The NVIDIA issue to which you refer is being addressed in another bug report and I am not seeing any issues there. This only breaks when I enable Xinerama. I can get everything running with Xinerama disabled I just get two xsessions with KDE - display :0.0 and :0.1

Gnome deals with multi-xsessions and joins them however KDE does not.

Can someone please take a look at this? The nouveau driver refuses to work in my configuration.

Phil

Comment 15 Matěj Cepl 2010-11-09 17:01:58 UTC
(In reply to comment #14)
> I really hate these type of knee jerk responses. This is NOT a NVIDIA problem. 

It is very easy. Show me. To quote myself: "If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, ...".

We know that nvidia driver replaces plenty of code which is not strictly speaking a driver, so on Xorg where it is installed we are really not certain what we have. Moreover, we don't have testing machines with nvidia driver installed so we are not able to reproduce your problem.

I am really sorry we cannot help you better. Try to reproduce the bug with nouveau driver and I'll see what we can do.

Thank you

Comment 16 phil.hopkins 2010-11-11 16:35:16 UTC
By the way this issue was identified and a patch issued by the folks at Archlinux and Gentoo. The patch was submitted - http://lists.x.org/archives/xorg-devel/2010-October/014150.html

I rebuilt the Fedora 14 xorg-x11-server RPMs using the patch and everything now works. 

As I stated all along the was not a nvidia issue, but was a xorg-xserver problem.

Comment 17 Rex Dieter 2010-11-11 16:46:54 UTC
Thanks.

(no one suggested that it wasn't an xorg-xserver issue, just that no one else could reproduce it on systems free of nvidia drivers...)

Comment 18 Mark T. Kennedy 2010-11-12 15:30:15 UTC
this bug is killing me.  how do i get a patched rpm?

Comment 19 Peter Backes 2010-11-13 01:04:40 UTC
The same problem is actually triggered by starting abiword. does anyone have rpms with the fix?

Comment 20 Peter Backes 2010-11-13 01:10:57 UTC
I found the rpms; they are at http://koji.fedoraproject.org/koji/buildinfo?buildID=204393

Note that this problem concerns all platforms, not only x86_64.

Comment 21 Fedora Update System 2010-11-23 16:13:49 UTC
xorg-x11-server-1.9.1-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.1-3.fc14

Comment 22 Fedora Update System 2010-11-23 21:58:02 UTC
xorg-x11-server-1.9.1-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-server'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.1-3.fc14

Comment 23 Fedora Update System 2010-11-26 01:04:16 UTC
xorg-x11-server-1.9.1-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.