Bug 649545 - Suspend inhibition does not work anymore
Summary: Suspend inhibition does not work anymore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: transmission
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-03 22:45 UTC by Julian Sikorski
Modified: 2010-11-18 23:59 UTC (History)
4 users (show)

Fixed In Version: transmission-2.11-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-18 23:59:06 UTC
Type: ---


Attachments (Terms of Use)

Description Julian Sikorski 2010-11-03 22:45:55 UTC
Description of problem:
Once I updated to Fedora 14, transmission does not prevent suspend from kicking in. It worked fine in Fedora 13.

Version-Release number of selected component (if applicable):
transmission-gtk-2.11-1.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1. install transmission-gtk
2. enable hibernation inhibition
3. start downloading something
  
Actual results:
suspend kicks in

Expected results:
download is allowed to continue uninterrupted

Additional info:
This is especially inconvenient since the suspend inhibition applet seems to be disabled too, see bug 648072.

Comment 1 Julian Sikorski 2010-11-05 04:29:04 UTC
https://trac.transmissionbt.com/changeset/11344 might have a fix.

Comment 2 Rahul Sundaram 2010-11-06 11:48:53 UTC
Hey Charles, 

Do I cherry pick that patch or is there a new release coming up upstream anytime soon?

Comment 3 Charles Kerr 2010-11-06 13:54:22 UTC
2.12 will be out in 7-10 days from now

Comment 4 Charles Kerr 2010-11-06 14:04:45 UTC
Ah, excuse that last comment.  I was reading the 2.11 note and was not thinking about how this issue exists in 2.04 as well.

Yes, I've been considering rolling a 2.05 release to contain these fixes: http://tinyurl.com/34yc4z7

If this is something that Fedora would push for F14 users I'd be happy to roll 2.05.

Comment 5 Julian Sikorski 2010-11-06 14:09:06 UTC
Fedora 14 is already at 2.11.

Comment 6 Charles Kerr 2010-11-06 14:45:04 UTC
F14 pushed a 2.11 update??  Wow that's pretty great...

I didn't know that because I have to shuffle my too-small-pre-F13 boot partition around before I can upgrade to F14. :)

Anyway.. alright then, back to my original comment.  2.12 is due out in [7...10] days.

Comment 7 Rahul Sundaram 2010-11-06 18:50:47 UTC
Yes 2.11 was a post release update at

https://admin.fedoraproject.org/updates/transmission-2.11-1.fc14

I thought we had discussed that push but perhaps not considering I didn't do it. Anyway, I will wait for the 2.12 release and pushed that out assuming it is primarily a bug fix release.

Comment 8 Charles Kerr 2010-11-07 03:08:18 UTC
This is a very good point.  Due to forces beyond my control, 2.12 is going to have a couple of non-bugfix changes, which is atypical for a Transmission point release.

As an upstream dev, I'm hardwired to recommend the latest and greatest version. :)   However, since this suspend inhibition fix is pretty simple (https://trac.transmissionbt.com/changeset/11344), I would understand if you chose to cherrypick that patch instead.

Rahul, contact me in IRC if you have questions about 2.12.

Comment 9 Rahul Sundaram 2010-11-07 18:03:14 UTC
I talked to Charles on IRC today and since the upcoming 2.12 release has a couple of feature changes that I don't want to push in an update, the plan in Fedora is to cherry pick the following important fixes and do an update by Thursday.  My co-maintainer Ankur Sinha will do this.  Just passing on the information and documenting the plan.  Thanks to Charles and Ankur.  

https://trac.transmissionbt.com/ticket/3629  (transmission-cli segfault)

https://trac.transmissionbt.com/ticket/3639 (inhibition breakage reported here)

https://trac.transmissionbt.com/ticket/3666 (byteCount stored on a 32bits integer)

Comment 10 Rahul Sundaram 2010-11-07 18:06:12 UTC
Ankur,  do note that 3629 needs a patch and its revision at r11330 and r11335.  The first ticket has the references.  These three bug fixes are fairly minimal but if you need any help, let me know offlist.

Comment 11 Rahul Sundaram 2010-11-07 21:39:42 UTC
Not to pile on but we should probably pull in https://trac.transmissionbt.com/ticket/3644 which was reported at https://bugzilla.redhat.com/show_bug.cgi?id=648745

Comment 12 Fedora Update System 2010-11-09 18:35:06 UTC
transmission-2.11-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/transmission-2.11-2.fc14

Comment 13 Fedora Update System 2010-11-10 01:17:31 UTC
transmission-2.11-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update transmission'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/transmission-2.11-2.fc14

Comment 14 Fedora Update System 2010-11-18 23:59:01 UTC
transmission-2.11-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.