Bug 650106 - Keyboard is not working until click to user. I cannot even switch to text console.
Keyboard is not working until click to user. I cannot even switch to text con...
Status: CLOSED DUPLICATE of bug 676827
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
15
Unspecified Unspecified
low Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15Alpha/F15AlphaBlocker
  Show dependency treegraph
 
Reported: 2010-11-05 04:40 EDT by Pavel Lisý
Modified: 2015-01-14 18:26 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-18 10:53:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Lisý 2010-11-05 04:40:59 EDT
Description of problem:
Keyboard is not working until click to user. I cannot even switch to text console.

Version-Release number of selected component (if applicable):
In Fedora 13/14 is the same problem
gdm-2.32.0-1.fc14.x86_64
gdm-2.30.2-1.fc13.x86_64

How reproducible:
Always when gdm is started after boot or after logoff prom previous session.

This problem seems to be HW specific. It appears on Lenovo ThinkPad X201 only. On other my computers it is working without problem.

Steps to Reproduce:
1. Boot computer 
2. Try to use keyboard 
3. No keyboard button is working
4. Click to on User menu in the middle of screen
5. Now keyboard started to work
  
Actual results:
Keyboard is locked/not working, you cannot even switch to different VT (text console)

Expected results:
Keyboard is working from beginning.

Additional info:
It is Fedora specific. In Ubuntu 10.04 on the same HW keyboard in gdm (2.30.2) is working OK.
Comment 1 Martin Tichacek 2010-12-13 10:30:38 EST
I can confirm same problem. Keyboard is blocked if no user is selected. 

It is not Lenovo related. I have two antique machines which suffers the same.

F.13 is on P4 1.8GHz,MB. MSI MS-6398 (intel chipset), Radeon 9200,HDD on "anonymous" S-ATA controller with SiI 3112 

F.14 machine: AMD Athlon 2500+, MB ASROCK (SIS chipset), VGA - onboard ...SIS, HDD - external toshiba on usb)

Both machines installed from dvd. (not an upgrade of old system)

At this time I do not have other machine with F13/14.

(US keyboard is selected for instalation and system use, European timezone)
Comment 2 Pavel Lisý 2010-12-13 11:13:38 EST
I've found the same problem on other of my machines. 

It is old noname PC (P4, 1.3GB ram, nvidia 96xx), new F14 installation from DVD.

On this machine F13 (in dual boot) keyboard works without problem in GDM.
Comment 3 Martin Tichacek 2010-12-13 12:02:23 EST
Ok. I have started F14 in kvm (installed from beta dvd) ... does not work too. 
But when i clicked accesibility and enabled keyboard on screen ... all keys are labeled as "<nil>" (and does not work too). After clicking at user, all buttons are labeled by their real names.

So, keyboard map missing?
Comment 4 Martin Tichacek 2010-12-25 18:26:11 EST
When Fedora 14 is installed in english language (default), keyboard is working. 

So, I have looked what is differrent in my "normal" configurations (where default language is czech, only with us keyboard).

in /etc/X11/00-system-setup-keyboard.conf is:

Option		"XkbVariant"	"qwerty"

In system installed in english, this line is commented out (and value set as "(null)".

When this line is commented (# on the beginning of line), keyboard is working fine. It seems to me, as us keyboard does not have "qwerty" keymap, so it returns those nulls. Czech keyboard has qwerty and qwertz variants. I expect, this is where it comes from. When czech language is selected, czech keyboadr is default, so when I chose us, there may be some remnants ...

It is, probably, a language specific. I have not tested other languages. My testing machine is really slow for full install.... and there may be some dificulties to understand different language :-D
Comment 5 Marcus Moeller 2011-02-15 09:28:18 EST






















































































Same situation on FC15 Alpha TC2, with German as installation language.
Comment 6 James Laska 2011-02-16 10:35:16 EST
@jmccann - do you have any input on this issue?  It's currently a proposed F15Alpha blocker because it impacts users of all non-english keyboard layouts.

The current proposed workaround involves clicking on the user name in the user list.
Comment 7 Pavel Lisý 2011-02-16 16:36:48 EST
When something goes wrong (ex. problem with graphics card or dual monitors setup) you wouldn't be able even to switch to text console (Ctrl-Alt-F2). 

So it could be pretty serious or annoying I think.
Comment 8 Matthias Clasen 2011-02-18 08:23:53 EST
This is an X bug where you end up with no usable keymap if a nonexisting
layout/variant combination is specified in /etc/sysconfig/keyboard.

Peter has a fix that is queued up upstream for the next X server release. Maybe we can get that patch in our packages.

Workaround: remove variants line from /etc/sysconfig/keyboard
Comment 9 Ray Strode [halfline] 2011-02-18 10:53:58 EST

*** This bug has been marked as a duplicate of bug 676827 ***

Note You need to log in before you can comment on or make changes to this bug.