Bug 676827 - keyboard with german layout doesn't work in gdm
keyboard with german layout doesn't work in gdm
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 650106 676415 (view as bug list)
Depends On:
Blocks: F15Alpha/F15AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-02-11 07:41 EST by Thomas Meyer
Modified: 2011-03-09 11:19 EST (History)
21 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.9.99.1-6.20101201.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-25 23:39:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/gdm/:0.log Xorg log file (17.86 KB, text/plain)
2011-02-11 07:41 EST, Thomas Meyer
no flags Details
keyboard config with variant (79 bytes, text/plain)
2011-02-25 12:36 EST, Julian
no flags Details

  None (edit)
Description Thomas Meyer 2011-02-11 07:41:11 EST
Created attachment 478232 [details]
/var/log/gdm/:0.log Xorg log file

Description of problem:
keyboard with german layout doesn't work in gdm. I even cannot switch to the virtual terminals!

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Julian 2011-02-11 16:37:37 EST
I see the same problem on x86_64 with two german keyboards, on both usb and ps2. X detects them properly according to Xorg logs, but closes all keyboard devices in the end.

If somebody wants, i can attach the logs, but they really look quite the same as Thomas'.
Comment 2 Martin-Gomez Pablo 2011-02-13 08:28:46 EST
Same problem with a french keyboard. My work around is to boot with init 3 and then use startx
Comment 3 Martin-Gomez Pablo 2011-02-13 08:35:20 EST
I forgot to mention that the function keys work : I can change the brightness and the sound level without problem in GDM
Comment 4 Thorsten Leemhuis 2011-02-18 03:02:04 EST
Same here sice a few days (x86_64)
Comment 5 Ray Strode [halfline] 2011-02-18 10:52:57 EST
whot fixed this upstream i believe.

If you edit /etc/sysconfig/keyboard and remove the line mentioning VARIANT
then run

systemctl enable system-setup-keyboard.service

and reboot everything should start working.
Comment 6 Ray Strode [halfline] 2011-02-18 10:53:59 EST
*** Bug 650106 has been marked as a duplicate of this bug. ***
Comment 7 James Laska 2011-02-18 11:09:12 EST
(In reply to comment #6)
> *** Bug 650106 has been marked as a duplicate of this bug. ***

Carrying forward blocks:F15Alpha from bug#650106.  We will discuss this issue, and the workaround in comment#5 at the Alpha blocker meeting (http://lists.fedoraproject.org/pipermail/test-announce/2011-February/000188.html)
Comment 8 Adam Williamson 2011-02-18 13:15:46 EST
Can anyone say for sure whether this hits fresh installs (or live boots), or only updates? Reporters? Ray? Thanks.
Comment 9 Adam Williamson 2011-02-18 13:19:23 EST
Desktop team is not sure, so reporters, can you please test a fresh F15 live image - such as http://serverbeach1.fedoraproject.org/pub/alt/stage/15-Alpha.TC2/Live/ - and see if you hit this? Thanks!
Comment 10 Robyn Bergeron 2011-02-18 13:21:00 EST
Per 2011-02-18 Alpha blocker meeting: #agreed 676827 - Unable to accept or reject.  Need more information from reporter (fresh install or upgrade)
Comment 11 Thomas Meyer 2011-02-18 13:40:51 EST
I did an upgrade via yum.
Comment 12 James Laska 2011-02-18 14:30:20 EST
(In reply to comment #11)
> I did an upgrade via yum.

Has anyone managed to hit this bug after a fresh install?
Comment 13 James Laska 2011-02-18 15:14:31 EST
After further review during Blocker review meeting (http://meetbot.fedoraproject.org/fedora-bugzappers/2011-02-18/f15-alpha-bug-review.2011-02-18-17.00.html) ...

AGREED: 676827 remove from F15Alpha, acceptable workaround exists, *suspect* this only affects upgrades (not install)
Comment 14 Raphos 2011-02-18 16:09:35 EST
Hi,

After a fresh alpha install, french latin9 keyboard don't work in gdm logging screen.

Workaround, boot in init3 change lain9 with system-config-keyboard with us keyboard.

(the screen system-config-keyboard in init3 have a display problem too...)
Comment 15 Adam Williamson 2011-02-19 02:37:59 EST
okay, that's not good: for me that makes this at *least* NTH.
Comment 16 Julian 2011-02-19 04:59:29 EST
Hey,

my system was setup with an f14 dvd and enabled rawhide repo.

The workaround in comment #5 works for me, but leaves me with an english keyboard layout during login. needless to say i dont know if that was the case without the workaround...
Comment 17 Felix Kaechele 2011-02-23 15:49:05 EST
Did a fresh install from F15 Alpha RC netinstall.
Hit this bug and used the workaround from comment #5.
That worked.
Comment 18 Adam Williamson 2011-02-23 18:38:50 EST
After extended discussion at the 2011-02-23 go/no-go meeting, we agreed this bug constitutes an Alpha blocker under the criterion "In most cases, the installed system must boot to a functional graphical environment without user intervention (see Blocker_Bug_FAQ) " - as it results in an unusable gdm if certain keyboard layouts are selected. Contrary to what was thought at previous meetings, this bug does not affect only upgrades, it affects new installs.

We believe this affects any keyboard layout which sets the VARIANT key in /etc/sysconfig/keyboard .
Comment 19 Peter Hutterer 2011-02-23 20:11:47 EST
*** Bug 676415 has been marked as a duplicate of this bug. ***
Comment 20 Fedora Update System 2011-02-23 21:22:11 EST
xorg-x11-server-1.9.99.1-5.20101201.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.99.1-5.20101201.fc15
Comment 21 Sandro Mathys 2011-02-24 05:45:10 EST
The updates above works as supposed, i.e. from bodhi:
"If the configured keymap is invalid, use the default keyboard layout instead."

So now, I choose the Swiss German layout during installation (which works in firstboot, btw) but in gdm I'm suddenly confronted with US layout. But that enables switching to a tty at least (where the SG layout works).

I figure that's an improvement but not really the fix we're looking for here.

Nevertheless, that might be enough to reconsider this common_bugs for the alpha so as not to further block the release.
Comment 22 Adam Williamson 2011-02-24 12:15:08 EST
I think we should really try to fix it properly. Peter, do you know the cause of the above, or should we re-assign this back to s-s-k / gdm?
Comment 23 Peter Hutterer 2011-02-24 17:41:07 EST
i don't know the cause yet but it's not in the server and not in gdm. It's either s-s-k or system-config-keyboard (reassigning to s-s-k for now)

The problem is simply that an invalid configuration is selected, i.e. layout + a variant that doesn't exist. The server patch is just to stop the worst outcome, a missing keymap but it doesn't fix the actual problem.


meanwhile, can I please have Xorg.log, /etc/sysconfig/keyboard and  /etc/X11/xorg.conf.d/00-system-setup-keyboard.conf from a broken install? thanks
Comment 24 Fedora Update System 2011-02-24 22:13:46 EST
xorg-x11-server-1.9.99.1-6.20101201.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.99.1-6.20101201.fc15
Comment 25 Peter Hutterer 2011-02-24 22:16:26 EST
xserver bug after all, above update fixes it for the install case. 
Note that if /etc/sysconfig/keyboard lists an invalid layout due to a manual edit, the server will still fall back to the build-in default ('us').
Comment 26 Wolfgang Ulbrich 2011-02-25 05:05:59 EST
With the updated packages i have my german-keyboard layout after login in xfce.
But there is another problem!
If i used the return-key from the keyboard to confirm, login is not possible. I'm falling back to the begin of the login.
It only works if i confirm with a mouse klick.
Comment 27 Sandro Mathys 2011-02-25 05:12:13 EST
I can also confirm this fix solves the problem (for Swiss German layout, that is).

raveit65: what you're additionally describing sounds like a different bug - please report it separately (or look whether there's already such a report, I think I've heard that before).
Comment 28 Adam Williamson 2011-02-25 11:19:54 EST
raveit: that's https://bugzilla.redhat.com/show_bug.cgi?id=679171 .
Comment 29 Julian 2011-02-25 12:34:06 EST
reinstalled with alpha rc1 and hit the bug again with my german keyboard.
installing updated xorg fixed the problem.

will post my X logs and /etc/sysconfig/keyboard.
Comment 30 Julian 2011-02-25 12:36:24 EST
Created attachment 481040 [details]
keyboard config with variant
Comment 31 Julian 2011-02-25 12:37:37 EST
i guess you need the Xorg logs with unfixed X, so ill downgrade later and attach logs. not enough time right now...
Comment 32 Adam Williamson 2011-02-25 12:58:45 EST
julian: i think we're fine now we've identified the issue and a fix, but thanks.
Comment 33 Fedora Update System 2011-02-25 18:18:20 EST
xorg-x11-server-1.9.99.1-6.20101201.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-server'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.99.1-6.20101201.fc15
Comment 34 Fedora Update System 2011-02-25 23:39:22 EST
xorg-x11-server-1.9.99.1-6.20101201.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 35 Sandro Mathys 2011-02-28 09:20:45 EST
Just to quickly confirm this again: works in F15 alpha RC2
Comment 36 Fedora Update System 2011-03-09 11:19:51 EST
xorg-x11-server-1.10.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.10.0-2.fc15

Note You need to log in before you can comment on or make changes to this bug.