This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 65012 - pdf2ps gives errors on certain .pdf files
pdf2ps gives errors on certain .pdf files
Status: CLOSED DUPLICATE of bug 74169
Product: Red Hat Linux
Classification: Retired
Component: ghostscript (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-15 19:40 EDT by Gérard Milmeister
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-15 11:35:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file for which pdf2ps segfaults (1.25 MB, application/octet-stream)
2002-05-15 19:43 EDT, Gérard Milmeister
no flags Details
file for which pdf2ps generates an error (93.27 KB, application/octet-stream)
2002-05-15 19:49 EDT, Gérard Milmeister
no flags Details
error message for pdf2ps Uebung8.pdf (1.43 KB, text/plain)
2002-05-15 19:50 EDT, Gérard Milmeister
no flags Details

  None (edit)
Description Gérard Milmeister 2002-05-15 19:40:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.1 (X11; Linux i686; U;) Gecko/20020417

Description of problem:
pdf2ps crashes with a segmentation fault,
on one file included as an attachment. On
the other it crashes with the error message
include

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. pdf2ps Graphen.4.pdf
2. segmentation fault
3. pdf2ps Uebung8.pdf
4. Unrecoverable error
	

Additional info:
Comment 1 Gérard Milmeister 2002-05-15 19:43:36 EDT
Created attachment 57504 [details]
file for which pdf2ps segfaults
Comment 2 Gérard Milmeister 2002-05-15 19:49:23 EDT
Created attachment 57505 [details]
file for which pdf2ps generates an error
Comment 3 Gérard Milmeister 2002-05-15 19:50:27 EDT
Created attachment 57506 [details]
error message for pdf2ps Uebung8.pdf
Comment 4 Tim Waugh 2002-05-22 07:06:31 EDT
The segmentation fault is fixed in 7.05-3 (in rawhide), but the 'undefined' 
error persists.
Comment 5 Alex Cherepanov 2002-10-15 11:35:02 EDT
The /undefined in NR is the same problem as #74169

The PDF file is incorrect.
One of the fonts in the file uses /NP procedure but doesn't define it.
Acrobat Reader and other PDF-only interpreters don't see the problem
because they don't execute PostScript code in Type 1 font.

On Ghostscript this procedure can be defined from command line.
gs -c "/NP{noaccess put}bind def" -f Uebung8.pdf
Comment 6 Tim Waugh 2002-10-15 12:21:04 EDT

*** This bug has been marked as a duplicate of 74169 ***

Note You need to log in before you can comment on or make changes to this bug.