Bug 74169 - pdflatex output crashes ghostscript
pdflatex output crashes ghostscript
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
: 65012 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-17 04:00 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-01 11:04:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample file (32.64 KB, application/octet-stream)
2002-10-15 10:43 EDT, Alex Cherepanov
no flags Details

  None (edit)
Description Need Real Name 2002-09-17 04:00:15 EDT
Description of Problem:


The PDF file produced by the sample file below on a Red Hat 7.3 Linux
system crashes Ghostscript 6.51, whether directly by viewing the file
using gv, or indirectly when trying to print from acroread, or by invoking
pdf2ps.  (pdftops works, but produces a postscript file that also crashes
ghostscript.)  I would have rated this as a Ghostscript bug, except
that on a machine with an older version of pdftex (pdfTeX-0.13d, which
produces PDF version 1.2) and an older version of Ghostscript (version
5.5) the error does not occur.  When trying out various combinations,
the PDF file from pdfTeX-0.13d worked on both Ghostscripts and the one
from pdfTeX-0.14h worked on neither.

Version-Release number of selected component (if applicable):


How Reproducible:

\documentclass{article}
\usepackage{charter}
\title{}
\author{Author  \\ \texttt{email@address} }
\date{}
\begin{document}
\maketitle
\thispagestyle{empty}
\end{document}


Steps to Reproduce:
1. Create the above file as bug.tex
2. pdflatex bug
3. gv bug.pdf

Actual Results:

gv crashes.

Expected Results:

gv displays the file.

Additional Information:

The error disappears if any of the following factors is not present:
1. Use of a psnfss package that does not redefine typewriter font.
   (utopia also gives the error, times and palatino do not)
2. The first line of \author.
3. The second line of \author.
4. Font change inside \author.

An expert on tetex told me this:

"The bug report also shows that RedHat has messed up the map files that
pdftex uses.

"Using the old pdfTeX, Version 3.14159-13d that is contained in teTeX-1.0
or the new pdfTeX, Version 3.14159-1.00b-pretest-20020211-HO20020731
that is contained in teTeX-beta, I get a 100% correct pdf file
from compiling your TeX source.

"I'd say: forget about that teTeX rpm's of RedHat... A clean
teTeX-stable or teTeX-beta can be downloaded from
  http://tug.org/teTeX/"

Whereas this suggestion might work for me, I guesss you would like to do
better than that.
Comment 1 Tim Waugh 2002-09-17 04:04:33 EDT
Since xpdf shows this file correctly I think this is a ghostscript problem.
Comment 2 Alex Cherepanov 2002-10-14 12:34:21 EDT
Please generate and submit a sample PDF file.
Comment 3 Alex Cherepanov 2002-10-15 10:43:57 EDT
Created attachment 80484 [details]
sample file
Comment 4 Alex Cherepanov 2002-10-15 11:01:06 EDT
The PDF file is incorrect.
One of the fonts in the file uses /NP procedure but doesn't define it.
Acrobat Reader and other PDF-only interpreters don't see the problem
because they don't execute PostScript code in Type 1 font. This file
fails on Adobe PostScript 3 with the same error as on Ghostscript.

On Ghostscript this procedure can be defined from command line.
gs -c "/NP{noaccess put}bind def" -f bug.pdf
Comment 5 Tim Waugh 2002-10-15 12:20:57 EDT
*** Bug 65012 has been marked as a duplicate of this bug. ***
Comment 6 Tim Waugh 2002-10-15 12:23:09 EDT
Changing component.
Comment 7 Leonard den Ottolander 2004-07-01 11:04:48 EDT
Current version of pdflatex (2.0.2-8 on FC 1) produces correct output.

Note You need to log in before you can comment on or make changes to this bug.