Bug 650206 - Crashes during disconnection if a PEP alias request is in-flight
Summary: Crashes during disconnection if a PEP alias request is in-flight
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: telepathy-gabble
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:861694720f1c59c0cb4fd54c71a...
Keywords:
: 650480 651547 657458 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-05 14:15 UTC by Matt Brown
Modified: 2019-01-09 12:54 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-02-24 06:34:05 UTC


Attachments (Terms of Use)
File: backtrace (14.40 KB, text/plain)
2010-11-05 14:15 UTC, Matt Brown
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 31412 None None None Never

Description Matt Brown 2010-11-05 14:15:52 UTC
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: /usr/libexec/telepathy-gabble
component: telepathy-gabble
crash_function: gabble_request_pipeline_enqueue
executable: /usr/libexec/telepathy-gabble
kernel: 2.6.35.6-45.fc14.i686
package: telepathy-gabble-0.10.3-1.fc14
rating: 4
reason: Process /usr/libexec/telepathy-gabble was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1288964533
uid: 4866

How to reproduce
-----
1. Opened Empathy settings/preferences
2. Changed the "Resource" of an existing Jabber account from empty to a value
3.

Comment 1 Matt Brown 2010-11-05 14:15:54 UTC
Created attachment 458096 [details]
File: backtrace

Comment 2 Brian Pepple 2010-11-09 19:36:41 UTC
*** Bug 651547 has been marked as a duplicate of this bug. ***

Comment 3 Brian Pepple 2010-11-17 14:21:41 UTC
*** Bug 650480 has been marked as a duplicate of this bug. ***

Comment 4 NM 2010-11-19 17:50:50 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Crashed at close

Comment
-----
.

Comment 5 Bob 2010-11-22 15:46:01 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


Comment
-----
Saw Network Error messages for AIM, Google, and Jabber.  Then, gabble crashed.

Comment 6 Brian Pepple 2010-12-02 14:55:13 UTC
*** Bug 657458 has been marked as a duplicate of this bug. ***

Comment 7 Brian Pepple 2010-12-02 14:56:47 UTC
Looks like this will be fixed in tp-gabble-0.10.5 (which should be released fairly soon)

Comment 8 Bob 2010-12-05 02:34:20 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.
3.

Comment 9 Mattias Ellert 2010-12-06 13:30:48 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Happend during start-up of empathy.

Comment 10 Bob 2010-12-24 11:27:52 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.
3.

Comment 11 Bob 2010-12-25 15:45:15 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.
3.

Comment 12 Bob 2010-12-27 10:12:02 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.
3.

Comment 13 Bob 2010-12-29 10:29:45 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.Gmail and Jabber sometimes reported Network Error or No Reason Specified (?)
3.Using satellite ISP with intermittent connection.

Comment 14 Bob 2011-01-02 10:54:27 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.May have seen "No reason given" or "Network Error".
3.Have intermittent internet connection - satellite ISP.

Comment 15 Bob 2011-01-05 10:38:57 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.Showed message: "No reason given"
3.

Comment 16 Bob 2011-01-08 11:22:08 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.Displayed message: "No reason given."
3.

Comment 17 Bob 2011-01-09 08:40:38 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.
3.

Comment 18 Bob 2011-01-10 11:34:02 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.
3.

Comment 19 Bob 2011-01-11 10:48:05 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.Saw messages: "No reason given.", "Network Error."
3.

Comment 20 Matt Brown 2011-01-12 13:48:00 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Telepathy was idle
2. Right-clicked on the icon in the panel and chose Quit
3.

Comment 21 Bob 2011-01-13 10:40:40 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.
3.

Comment 22 Bob 2011-01-14 14:17:36 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.Internet connection may have been interrupted. (satellite ISP)
3.

Comment 23 Bob 2011-01-15 09:51:27 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Empathy was idle.
2.
3.

Comment 24 Marcin Winkiewicz 2011-01-30 20:31:50 UTC
Package: telepathy-gabble-0.10.4-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I shut down empathy

Comment 25 Fedora Update System 2011-02-16 20:16:13 UTC
telepathy-gabble-0.10.5-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/telepathy-gabble-0.10.5-1.fc14

Comment 26 Fedora Update System 2011-02-17 00:51:27 UTC
telepathy-gabble-0.10.5-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update telepathy-gabble'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/telepathy-gabble-0.10.5-1.fc14

Comment 27 Fedora Update System 2011-02-24 06:33:59 UTC
telepathy-gabble-0.10.5-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.