Bug 65025 - Broken polish keyboard in KDE3
Summary: Broken polish keyboard in KDE3
Status: CLOSED DUPLICATE of bug 64559
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-16 09:57 UTC by Wojciech Kazubski
Modified: 2007-04-18 16:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-24 08:34:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wojciech Kazubski 2002-05-16 09:57:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-3 i686)

Description of problem:
Polish keyboard is broken after upgrading from RH7.2  (KDE2.2.2) to RH7.3
(KDE3).
Pressing <Alt> +a gives <ae> instead of a with ogonek
Pressing <Alt>+c gives slashed c instead of accented c  (0xE6)
Pressing <Alt>+e gives ordinary e
etc...
Only slashed l (lower and uppercase) are OK.
The pl2 keyboard is broken too (but z and y are switched as expected)
After switching from pl2 to pl keyboard z and y remain switched.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade RH7.2 to RH7.3 with KDE3, polish locale (or install RH7.3) configure
pl as main keyboard and 
2. Open KEdit or other editor
3. Press Right <Alt> and a
	

Actual Results:  (ae( character appears in KEdit

Expected Results:  (a( with ogonek 

Additional info:

Affects any KDE application. Tested on one computer.

Comment 1 Wojciech Kazubski 2002-05-16 11:33:24 UTC
After rebooting with polish keyboard enabled only slashed l and L are mapped
(correctly), other mappings are appearing after switching to us keboard and
remain active after switching back to pl. So I expect missing entries in
keyboard mapping file for pl keyboard.


Comment 2 Wojciech Kazubski 2002-05-22 16:23:55 UTC
Another observation:
each time the polish keyboard is selected, the message:

Error loading keymap /usr/X11R6/lib/X11/xkb/compiled/server-0.xkm

is appended to XFree86.0.log. I cant see any file except README there

Comment 3 Wojciech Kazubski 2002-05-24 07:56:28 UTC
This bug is in XFree86 4.2.0. 
Replacing the file /usr/X11R6/lib/X11/xkb/symbols/pl by a similar file taken
from XFree86 4.1.0 (RedHat 7.2) or commenting out (with //) the two lines
defining the Euro sign solves the problem until introduction of Euro in Poland.
This may help for some other national keyboards as pl2.


Comment 4 Jacek Piskozub 2002-05-24 08:34:12 UTC
Deleting the unnecessary comma after EuroSign in
/usr/X11R6/lib/X11/xkb/symbols/pl  and restarting X-server is enough to have the
Polish keyborad functionality restored.

Comment 5 Mike A. Harris 2002-05-25 01:39:08 UTC

*** This bug has been marked as a duplicate of 64559 ***


Note You need to log in before you can comment on or make changes to this bug.