Bug 650633 - [abrt] evolution-2.32.0-2.fc14: Process /usr/bin/evolution was killed by signal 6 (SIGABRT)
Summary: [abrt] evolution-2.32.0-2.fc14: Process /usr/bin/evolution was killed by sign...
Keywords:
Status: CLOSED DUPLICATE of bug 650203
Alias: None
Product: Fedora
Classification: Fedora
Component: libsoup
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e1d8b933c0c4ec7d5bda9cb626a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-07 14:06 UTC by BartS
Modified: 2012-07-10 17:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-10 17:19:54 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (29.56 KB, text/plain)
2010-11-07 14:06 UTC, BartS
no flags Details

Description BartS 2010-11-07 14:06:53 UTC
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: evolution
component: evolution
executable: /usr/bin/evolution
kernel: 2.6.35.6-48.fc14.i686
package: evolution-2.32.0-2.fc14
rating: 4
reason: Process /usr/bin/evolution was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1289138646
uid: 500

How to reproduce
-----
1. Send email
2. Evolution hangs (note it often reports an error while sending but appears to succeed, however this time it hung, and after a couple of minutes I kill -6'd it.
3.

Comment 1 BartS 2010-11-07 14:06:55 UTC
Created attachment 458461 [details]
File: backtrace

Comment 2 Milan Crha 2010-11-08 09:19:10 UTC
Could be libsoup issue, thus moving there. Unless caused by evolution-exchange usage, where the function is called from the main thread.

Thread 1 (Thread 4306):
#0  0x002f1416 in __kernel_vsyscall ()
#1  0x0095798b in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:169
#2  0x06fd1a66 in process_queue_item (item=0x95320d0) at soup-session-sync.c:280
#3  0x06fd1b61 in send_message (session=0x9805e98, msg=0xa287368) at soup-session-sync.c:365
#4  0x06fce054 in soup_session_send_message (session=0x9805e98, msg=0xa287368) at soup-session.c:1575
#5  0x07c06465 in e2k_context_send_message (ctx=0x928cf20, op=0x0, msg=0xa287368) at e2k-context.c:930
#6  0x07c0796e in e2k_context_proppatch (ctx=0x928cf20, op=0x0, uri=0xb018d880 "https://owa03.falconstor.com/exchange/Bart.Steanes/Inbox/MME-2.EML", props=0xa2a2b50, create=0, repl_uid=0x0) at e2k-context.c:1491
#7  0x029122fe in process_flags (user_data=0xb016dea0) at camel-exchange-utils.c:1392
#8  0x00a028fd in g_timeout_dispatch (source=0x9adf7e0, callback=0x2911eb0 <process_flags>, user_data=0xb016dea0) at gmain.c:3585
#9  0x00a01192 in g_main_dispatch (context=0x91d5f70) at gmain.c:2149
#10 g_main_context_dispatch (context=0x91d5f70) at gmain.c:2702
#11 0x00a01978 in g_main_context_iterate (context=0x91d5f70, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#12 0x00a0204b in g_main_loop_run (loop=0x93a1b68) at gmain.c:2988
#13 0x0556e499 in IA__gtk_main () at gtkmain.c:1237
#14 0x0804a027 in main (argc=1, argv=0xbfeb6544) at main.c:671

Comment 3 Dan Winship 2010-12-02 18:15:17 UTC
Milan, any reason you think it was crashing in the libsoup thread?

AFAICT, *none* of the threads in the backtrace is the source of the SIGABRT...

Comment 4 Milan Crha 2010-12-02 19:04:58 UTC
It's hung in the main thread waiting on some lock in libsoup, then BartS killed it with -6, so the backtrace shows just the snap what it was doing in the time of the hang. The other threads seem to be just waiting on a command, like any other time, so even Thread 1 is also waiting, I believe it is not a usual waiting task.

Comment 5 Dan Winship 2010-12-02 19:44:51 UTC
oh, in that case this is almost definitely a dup of bug 650203.

BartS: can you try the packages at http://koji.fedoraproject.org/koji/buildinfo?buildID=207405 (click the download link next to libsoup-2.32.2-1.fc14.i686.rpm)

or, if the bug was just a one-time thing and not reproducible, then we can just mark this a dup of 650203.

Comment 6 Dan Winship 2012-07-10 17:19:54 UTC
never got a response; assume this is a dup as per comment 5

*** This bug has been marked as a duplicate of bug 650203 ***


Note You need to log in before you can comment on or make changes to this bug.