Bug 650203 - Evolution using exchange plugin, just hangs getting email.
Summary: Evolution using exchange plugin, just hangs getting email.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-exchange
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 650633 654601 655500 657645 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-05 14:10 UTC by Nathan Crubel
Modified: 2012-07-10 17:19 UTC (History)
6 users (show)

Fixed In Version: libsoup-2.32.2-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-09 15:16:45 UTC
Type: ---


Attachments (Terms of Use)
Backtrace of running evolution (47.58 KB, application/octet-stream)
2010-11-08 13:48 UTC, Russell Harrison
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 634422 None None None Never

Description Nathan Crubel 2010-11-05 14:10:22 UTC
Description of problem:  When starting up exchange, it will start looking for new mail, somtimes goes to 100% and then does nothing.  


Version-Release number of selected component (if applicable): 2-32


How reproducible: Start up evolution


Steps to Reproduce:
1. Connect to an exchange email system
2. Let it start to get mail
3. Watch it just sit there and do nothing
  
Actual results:
Not Able to use Evolution instead of outlook

Expected results:
Able to use Evolution instead of outlook.

Additional info:
This is an upgrade of Fedora 13 to Fedora 14.  Fedora 13 exchange still working fine.  Have tried gdb debugging and loading in terminal.  Shows nothing helpful.  Just stops, still shows like it is trying.

Comment 1 Milan Crha 2010-11-05 15:19:47 UTC
Thanks for a bug report. What does it mean "Shows nothing helpful", please? Is it evolution-exchange or evolution-mapi used here?

Comment 2 Nathan Crubel 2010-11-06 03:32:33 UTC
it is the evolution-exchange plugin.  It show no errors on debug when connecting to mail.  It just hangs and with no network activity.

Comment 3 Milan Crha 2010-11-08 11:10:16 UTC
Thanks for the update. Could you install debug info packages for evolution-exchange, evolution-data-server and evolution, and then, when it hangs, get a backtrace of running evolution, to see what it does behind the scene, please? You can do that by this:
a) run evolution from console
b) get a process ID (PID) of running evolution
   $ ps -A | grep evolution

c) reproduce the hang and while it is hanged invoke this on another console:
   $ gdb --batch --ex "t a a bt" -pid=PID &>bt.log
   (replace PID with the actual process ID from step b))

Finally make sure the resulting bt.log file will not contain any private information, like server addresses, user names, email addresses or passwords you do not want to share, and upload it here. Thanks in advance.

Comment 4 Russell Harrison 2010-11-08 13:48:32 UTC
Created attachment 458740 [details]
Backtrace of running evolution

This is a backtrace of evolution running with many running tasks on the bottom toolbar with the title "Scanning for changed messages (0% complete)" that never seem to finish.

Comment 5 Milan Crha 2010-11-08 14:21:02 UTC
Thanks for the update. I see that all evolution-exchange related threads are just waiting with sending a message through libsoup, same like this one:

Thread 3 (Thread 0x9ddfab70 (LWP 5923)):
#0  0x00d40424 in __kernel_vsyscall ()
#1  0x0094f98b in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:169
#2  0x036eca66 in process_queue_item (item=0xa78e6780) at soup-session-sync.c:280
#3  0x036ecb61 in send_message (session=0xa3e5a160 [SoupSessionSync], msg=0xa787d930 [SoupMessage]) at soup-session-sync.c:365
#4  0x036e9054 in soup_session_send_message (session=0xa3e5a160 [SoupSessionSync], msg=0xa787d930 [SoupMessage]) at soup-session.c:1575
#5  0x0541d465 in e2k_context_send_message (ctx=0x93cc040 [E2kContext], op=0x0, msg=0xa787d930 [SoupMessage]) at e2k-context.c:930
#6  0x0541d711 in search_fetch (iter=0x96a03b8, ctx=0x93cc040 [E2kContext], op=0x0, results=0x96a03c4, nresults=0x96a03c8, first=0x96a03d0, total=0x96a03d4, user_data=0x9389d68) at e2k-context.c:1922
#7  0x0542848d in iter_fetch (ctx=0x93cc040, op=0x0, ascending=1, total=-1, fetch_func=0x541d5f0 <search_fetch>, free_func=0x541ab10 <search_free>, user_data=0x9389d68) at e2k-result.c:471
#8  e2k_result_iter_new (ctx=0x93cc040, op=0x0, ascending=1, total=-1, fetch_func=0x541d5f0 <search_fetch>, free_func=0x541ab10 <search_free>, user_data=0x9389d68) at e2k-result.c:526
#9  0x0541f1e0 in e2k_context_search_start (ctx=0x93cc040 [E2kContext], op=0x0, uri=0x99ca248 "https://email.example.com/exchange/username/Inbox/it-dte-all/", props=0x18fe740, nprops=9, rn=0x9389d48, orderby=0x18d838c "DAV:creationdate", ascending=1) at e2k-context.c:1995
#10 0x05406a71 in e_folder_exchange_search_start (folder=0xa5a58ca8 [EFolderExchange], op=0x0, props=0x18fe740, nprops=9, rn=0x9389d48, orderby=0x18d838c "DAV:creationdate", ascending=1) at e-folder-exchange.c:729
#11 0x01873eaa in get_folder_contents_online (mfld=0xa782b898, error=0x0) at camel-exchange-utils.c:921
#12 0x01874865 in get_folder_contents_online_func (data=0xa782b898) at camel-exchange-utils.c:1103
#13 0x00a15bd0 in g_thread_create_proxy (data=0xa78022e8) at gthread.c:1897
#14 0x0094af19 in start_thread (arg=0x9ddfab70) at pthread_create.c:301
#15 0x00860a2e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Comment 6 Milan Crha 2010-11-09 15:16:45 UTC
I had a chat with libsoup developer and we decided to move this upstream [1], so he'll look on it. Please see [1] for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=634422

Comment 7 Milan Crha 2010-11-19 08:03:00 UTC
*** Bug 654601 has been marked as a duplicate of this bug. ***

Comment 8 Milan Crha 2010-11-22 10:27:15 UTC
*** Bug 655500 has been marked as a duplicate of this bug. ***

Comment 9 Dan Winship 2010-11-23 18:45:14 UTC
F14 packages that should hopefully fix the bug can be downloaded from

http://koji.fedoraproject.org/koji/taskinfo?taskID=2619785 (i686) and
http://koji.fedoraproject.org/koji/taskinfo?taskID=2619784 (x86_64).

(The RPM links are at the bottom.)

Can someone try it out and see if it fixes the problems?

Comment 10 Bojan Smojver 2010-11-23 21:45:41 UTC
(In reply to comment #9)
> F14 packages that should hopefully fix the bug can be downloaded from
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2619785 (i686) and
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2619784 (x86_64).
> 
> (The RPM links are at the bottom.)
> 
> Can someone try it out and see if it fixes the problems?

I'm running this now (i686). Obviously, given it's a deadlock, this will take some time to confirm either way. Will keep you posted.

Comment 11 Bojan Smojver 2010-11-23 23:04:20 UTC
(In reply to comment #10)
 
> I'm running this now (i686). Obviously, given it's a deadlock, this will take
> some time to confirm either way. Will keep you posted.

So far, so good. Opened/closed Evo probably 10 times. No hangs yet (also feels more snappy in terms of what threads down at the status bar are doing).

Comment 12 Nathan Crubel 2010-11-23 23:49:33 UTC
Working great, no hangs, downloading mail like a champ.  Calendar is working also with no problems.  Able to add appointments to my calendar.  Thanks everyone for getting this package out there.

Comment 13 Bojan Smojver 2010-11-24 22:21:29 UTC
(In reply to comment #11)

> So far, so good. Opened/closed Evo probably 10 times. No hangs yet (also feels
> more snappy in terms of what threads down at the status bar are doing).

Still no hangs, so looks like this is the fix. Thanks!

Comment 14 Bojan Smojver 2010-11-29 23:07:42 UTC
(In reply to comment #13)
 
> Still no hangs, so looks like this is the fix. Thanks!

Feel free to push that libsoup build as an update to F-14. Couldn't fault it since.

Comment 15 Milan Crha 2010-11-30 12:52:29 UTC
*** Bug 657645 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2010-12-02 18:03:20 UTC
libsoup-2.32.2-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libsoup-2.32.2-1.fc14

Comment 17 Dan Winship 2010-12-02 18:06:28 UTC
^^ this package is slighter newer than the scratch build I linked to earlier. (It includes a fix for gupnp too.) Please try it out and give it karma if it works.

Comment 18 Fedora Update System 2010-12-12 20:04:18 UTC
libsoup-2.32.2-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Dan Winship 2012-07-10 17:19:54 UTC
*** Bug 650633 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.