Bug 65091 - emacs backspace should delete backwards in a tty
Summary: emacs backspace should delete backwards in a tty
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: screen   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 65090 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-17 08:21 UTC by Jens Petersen
Modified: 2007-04-18 16:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-12 14:26:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2002-05-17 08:21:53 UTC
Description of problem:
In an Emacs session in a tty, backspace should delete not put
in the help keymap.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. emacs -q
2. Press Backspace


Actual Results:  C-h (Type ? for further options)-

Expected Results:  The character before point should have been deleted.

Additional info:
(normal-erase-is-backspace-mode) seems to fixes the problem.

Comment 1 Trond Eivind Glomsrxd 2002-07-11 16:36:39 UTC
That's already what I have happening.... no changes, "-q" used in gnome terminal
and console mode. Which tty are you thinking of?

Comment 2 Jens Petersen 2002-07-12 07:14:46 UTC
Sorry, this is inside a screen session.

1. screen
2. emacs -nw -q
3. Backspace

Puts me into help mode.  Looks like it's a screen config bug?

1. SYSSCREENRC=/dev/null SCREENRC=/dev/null screen
2. emacs -nw -q
3. Backspace

works fine.


Comment 3 Jens Petersen 2002-07-12 07:40:22 UTC
*** Bug 65090 has been marked as a duplicate of this bug. ***

Comment 4 Jens Petersen 2002-07-12 07:52:42 UTC
It seems to be because of

bindkey -d -k kb stuff "\010"

in "/etc/screenrc".  Could it be commented out?

Comment 5 Phil Copeland 2002-08-12 19:09:44 UTC
Fixed in current rawhide

Phil
=--=

Comment 6 Jens Petersen 2002-08-14 10:52:31 UTC
Fix confirmed.  Thanks.

Comment 7 David Balažic 2004-06-18 11:40:16 UTC
Also see bug 11294 for reference on this problem.


Note You need to log in before you can comment on or make changes to this bug.