Bug 65094 - jobs are left in the printer queue after printing
Summary: jobs are left in the printer queue after printing
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: LPRng   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 62939 69759 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-17 10:24 UTC by Luca Bonomi
Modified: 2007-04-18 16:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 13:55:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luca Bonomi 2002-05-17 10:24:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
When I print jobs, they print correctly, but they are never removed from the
queue (though they get the rank "done") and the files are left in the
"/var/spool/lpd" directory.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Print a text file "lpr test"
2. Print a second test file "lpr test2"
3. Print a third test file "lpr test3"
4. View the queue "lpq"
	

Actual Results:  The jobs are printed correctly but 2 jobs are left in the spool
and not removed from the queue. You will see their status with the "lpq"
command. Actually, the two jobs are always the first and the last printed.

Expected Results:  The jobs should be removed and the files cleaned from the
spool directory

Additional info:

If I restart the lpd daemon, the last job is cleaned, but the first one remains
in the spool

Comment 1 Tim Waugh 2002-05-17 10:28:14 UTC
I believe that this is intentional.  See the CHANGES file.

Comment 2 Luca Bonomi 2002-05-17 11:24:37 UTC
I agree it is intentional to leave the last "N" printed jobs for status purposes, but I 
believe it is a bug that the 1st one you ever print is always there!

Comment 3 Tim Waugh 2002-05-17 11:39:27 UTC
Oh I see.  Yes.

Comment 4 Tim Waugh 2002-06-13 08:02:07 UTC
*** Bug 62939 has been marked as a duplicate of this bug. ***

Comment 5 Tim Waugh 2002-07-26 11:36:50 UTC
*** Bug 69759 has been marked as a duplicate of this bug. ***

Comment 6 Tim Waugh 2004-12-08 13:55:32 UTC
Closing, since we use CUPS now.


Note You need to log in before you can comment on or make changes to this bug.