Bug 69759 - done jobs aren't removed from the print queue.
done jobs aren't removed from the print queue.
Status: CLOSED DUPLICATE of bug 65094
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-24 20:52 EDT by Ian Mortimer
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-24 20:52:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Mortimer 2002-07-24 20:52:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

Description of problem:
lpd.conf has two options to control the removal of done jobs:
done_jobs and done_jobs_max_age.  However setting either or both of
those doesn't (consistently) cause done jobs to be removed as desired.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.edit lpd.conf
2.set done_jobs=0 or done_jobs_max_age to a small number
3.restart lpd
	

Actual Results:  Jobs which have printed (1 or 2 usually) are retained in the
queue marked as "done" until other print jobs come along to displace them.

Expected Results:  With done_jobs set to 0 no done jobs should be retained.
With done_jobs_max_age set to a small number the jobs should be removed 
after that many seconds.

Additional info:

The problem appears to be fixed in the latest LPRng: 3.8.13.

This causes problems with samba.  samba reports the done jobs back to
windows boxes which don't understand the "done" and display the jobs
as paused.  This confuses the users who don't realize their job has 
been printed.

I consider there is a bug with samba since it's samba's responsibility 
to communicate with Windows boxes, not LPRng's.  Nevertheless the options 
to turn off or control this feature exist in lpd.conf but don't work as 
advertised.
Comment 1 Tim Waugh 2002-07-26 07:36:54 EDT

*** This bug has been marked as a duplicate of 65094 ***
Comment 2 Ian Mortimer 2002-07-29 18:00:44 EDT
The strange thing is that I queried bugzilla for any bug reports relating to
LPRng and didn't find any relating to this question.  Querying bugzilla now only
shows mine and another unrelated report.  Why didn't I see bug # 65094 and why
don't I still see it?  Is this a bug in bugzilla is it a bug in my query technique?

Note You need to log in before you can comment on or make changes to this bug.