Bug 65098 - kdeinit resets/unloads Xresources
Summary: kdeinit resets/unloads Xresources
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 65137 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-17 14:44 UTC by Rex Dieter
Modified: 2007-04-18 16:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-30 15:48:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Makes KDE honour Xresources (just like 2.x) (1.16 KB, patch)
2002-05-22 15:59 UTC, Carlos Rodrigues
no flags Details | Diff

Description Rex Dieter 2002-05-17 14:44:15 UTC
In kdebase-3.0.0-12 (and rawhide's kdebase-3.0.1-1) , it appears that the  
kdeinit line in /usr/bin/startkde resets Xresources, ie, my ~/.Xresources are  
not being used/loaded. Only after I put  
 
if [ -f "$HOME/.Xresources" ]; then 
    xrdb -merge "$HOME/.Xresources" 
fi 
 
after the kdeinit step do my Xresources get loaded/used.  If xrdb is not used 
here, or put before the kdeinit step, the Xresources are once again not 
loaded.

Comment 1 Carlos Rodrigues 2002-05-20 00:15:30 UTC
The X resources also get reset after changing some colors in the KDE Control 
Center, whether "apply colors to non-KDE applications" is checked or not.

Comment 2 Bernhard Rosenkraenzer 2002-05-21 14:29:23 UTC
*** Bug 65137 has been marked as a duplicate of this bug. ***

Comment 3 Carlos Rodrigues 2002-05-22 15:59:56 UTC
Created attachment 58185 [details]
Makes KDE honour Xresources (just like 2.x)

Comment 4 Rex Dieter 2002-05-22 17:26:07 UTC
I can confirm that the patch works as advertised (against rawhide's 
kdebase-3.0.1-1).  Thanks!

Comment 5 Michael Schwendt 2002-07-30 18:33:52 UTC
Hmmm, while Limbo beta1 did not unload my ~./Xresources and worked as expected
with regard to this, the problem is back with Limbo beta2. Now both Valhalla and
Limbo beta2 do not accept my ~/.Xresources and I must load them manually.

That checkbox mentioned in a comment above does not affect this.



Note You need to log in before you can comment on or make changes to this bug.