Bug 65137 - KDE does not honor standard X resources.
KDE does not honor standard X resources.
Status: CLOSED DUPLICATE of bug 65098
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-17 22:29 EDT by Steven W. Orr
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-17 22:32:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven W. Orr 2002-05-17 22:29:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
I just upgraded from RH-7.2 to 7.3. My problem is that, for some reason, 
my backspace key no longer works in pine (as well as other problems). 
Here's my setup:

I have a correct value set for my XFILESEARCHPATH and my 
XUSERFILESEARCHPATH variables. In my $XUSERFILESEARCHPATH I have a file 
called XTerm-color and in my .xinitrc I have this one line

xrdb -load ~/.Xresources 2> /dev/null &

My .Xresources simply sez:
*customization: -color
*StringConversionWarnings: on

* In my XTerm-color I have (among other things)
*VT100*backarrowKey: true
*VT100.geometry:     80x72

For some reason, now when I start an xterm, it comes up with 24 lines 
instead of the desired 80 and the backarrow key no longer works in pine. 
Instead I have to use the ^H key. In fact all of the resource setting I 
specify no longer seem to work. The odd thing is that the resources seem 
to work fine in gnome. Under KDE, the behavior seems to be broken. I know 
there used to be a setting someplace that said something about how 
resources should be controlled by kde for non-kde apps. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.xrdb -load ~/.Xresources
This adds the -color value to *customization
2.Make sure that X*FILESEARCHPATH is set to contain %N%C for each directory
3.Result is that X resource files are not honored.
	

Additional info:

Please note that the value of my directories in XFILESEARCHPATH and
XUSERFILESEARCHPATH all correctly end in /%N%C and that my customization
resource (as specified above) is set to -color

I was able to fix the problem by adding the following lines to startkde after
the call to kdeinit. Here's the associated fragment:

# We set LD_BIND_NOW to increase the efficiency of kdeinit.
# kdeinit unsets this variable before loading applications.
LD_BIND_NOW=true kdeinit +kcminit +knotify || \
  xmessage -geometry 500x100 "Couldn't start kdeinit. Check your installation."

# Added by me
if [ -f "$HOME/.Xresources" ]; then
    xrdb -merge "$HOME/.Xresources"
fi
# End of Added by me
Comment 1 Bernhard Rosenkraenzer 2002-05-21 10:29:29 EDT

*** This bug has been marked as a duplicate of 65098 ***

Note You need to log in before you can comment on or make changes to this bug.