Bug 65102 - Exception when selecting eth0 and then clicking 'edit'
Exception when selecting eth0 and then clicking 'edit'
Status: CLOSED DUPLICATE of bug 65185
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Depends On:
  Show dependency treegraph
Reported: 2002-05-17 11:43 EDT by Jos Shepherd
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-05-17 17:12:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jos Shepherd 2002-05-17 11:43:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Here's the output:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 531, in on_deviceEditButton_clicked
    button = self.editDevice(device)
  File "/usr/sbin/neat", line 561, in editDevice
    cfg = ethernetConfigDialog(device)
line 61, in __init__
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/deviceconfig.py", line
71, in __init__
line 95, in hydrate
    sharedtcpip.hardware_hydrate (self.sharedtcpip_xml, self.device)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/sharedtcpip.py",
line 286, in hardware_hydrate
    hwlist = NCHardwareList.getHardwareList()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 353, in getHardwareList
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 134, in load
    wvdial = ConfSMB('/etc/wvdial.conf')
  File "/usr/lib/rhs/python/ConfSMB.py", line 34, in __init__
    merge=0, create_if_missing=0)
  File "/usr/lib/rhs/python/Conf.py", line 180, in __init__
  File "/usr/lib/rhs/python/ConfSMB.py", line 36, in read
  File "/usr/lib/rhs/python/Conf.py", line 258, in read
    raise FileMissing, self.filename + ' does not exist.'
Conf.FileMissing: /etc/wvdial.conf does not exist.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.load 'Network Configuration' from gnome start menu
2.click 'Devices'
3.click table entry for eth0
4.click 'Edit...'

Actual Results:  An unhandled exception window poped up and the program crashed.

Expected Results:  Some sort of edit window should have opened for the params my
network card.

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-05-17 12:38:24 EDT
Do you have any PPP interfaces? It tracebacks when trying to read a dialup
configuration file.
Comment 2 Jos Shepherd 2002-05-17 12:52:29 EDT
I don't use dial up/PPP and I have never set up PPP. My ethernet adapter is the only thing listed in 
the devices box.
Comment 3 Trond Eivind Glomsrxd 2002-05-17 17:12:11 EDT
Can you tar up the contents of /etc/sysconfig/network and
/etc/sysconfig/networking and attach it to the file? Can't reproduce it here.
Comment 4 Harald Hoyer 2002-06-26 10:32:27 EDT

*** This bug has been marked as a duplicate of 65185 ***

Note You need to log in before you can comment on or make changes to this bug.