Bug 651378 - Xorg caught signal 11 when kernel boot with nomodeset on dualhead x600 radeon
Summary: Xorg caught signal 11 when kernel boot with nomodeset on dualhead x600 radeon
Status: CLOSED DUPLICATE of bug 623824
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-09 12:52 UTC by ati.x600.fedora.14
Modified: 2018-04-11 14:30 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-11-10 09:22:05 UTC


Attachments (Terms of Use)
xorg.conf from pastebin (1.24 KB, text/plain)
2010-11-09 14:56 UTC, Matěj Cepl
no flags Details
Xorg.0.log from pastebin (76.25 KB, text/plain)
2010-11-09 14:56 UTC, Matěj Cepl
no flags Details

Description ati.x600.fedora.14 2010-11-09 12:52:08 UTC
Description of problem:
Troubles with dualhead video (Radeon x600) during boot.
I have a SONY digital TV attached to DVI out and LG CRT monitor attached to VGA out, S-video out is not used now.

When i try to boot with nomodeset text messages are shown on the both TV and monitor, but before switch to graphic mode Xorg caught signal 11 and died.
Here is Xorg.0.log http://pastebin.com/TY7qd12H

When i try to boot without nomodeset monitor turned off when boot begin and all text messages and gdm display in graphic mode are shown only on TV.
CRT is off untill I login into gnome. In gnome I have worked VGA monitor as first  monitor and TV as second.

kernel /boot/vmlinuz-2.6.35.6-48.fc14.x86_64 ro root=UUID=d783a245-2652-4e90-ac52-2bfcc24f975b rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us nomodeset 

In Fedora 12 I boot with such xorg.conf http://pastebin.com/mRc0P1yS
In fedora 12 it show gdm on both TV and monitor and after login I have display spanning on both TV and monitor.

Version-Release number of selected component (if applicable):
Work in xorg-x11-server-Xorg-1.7.6-4.fc12.x84_64
Failed in xorg-x11-server-Xorg-1.9.1-2.fc14

How reproducible:
Always on my PC

Steps to Reproduce:
1. Add nomodeset to kernel parameters and boot with two monitors
  
Actual results:
Xorg dies

Expected results:
Xorg alive and work

Additional info:

Comment 1 Matěj Cepl 2010-11-09 14:56:16 UTC
Created attachment 459130 [details]
xorg.conf from pastebin

Comment 2 Matěj Cepl 2010-11-09 14:56:23 UTC
Created attachment 459131 [details]
Xorg.0.log from pastebin

Comment 3 Matěj Cepl 2010-11-09 14:59:04 UTC
I think Xorg could work without any /etc/X11/xorg.conf. Let it startup in whatever mode it starts, and then set dual-monitors with gnome-desktop-properties (note the button "Make Default").

*** This bug has been marked as a duplicate of bug 623824 ***

Comment 4 ati.x600.fedora.14 2010-11-09 16:51:59 UTC
With nomodeset Xorg crash either with xorg.conf either without
Without nomodeset Xorg work but CRT monitor stays off till I login and  turns off when i log out.
with gnome-desktop-properties LG CRT monitor (F720P) set as first 1024x768@85Hz,
Sony TV placed in the right of LG and set as 1360x768@60Hz 

May be I described 2 different bugs?

Comment 5 ati.x600.fedora.14 2010-11-09 17:06:19 UTC
There is a repeated message in text console (CTRL-ALT-F1) 
[ 1414.118918] [drm] crtc 1 is connected to a TV

Comment 6 ati.x600.fedora.14 2010-11-09 21:23:02 UTC
Solved without nomodeset

With gnome-display-properties generated monitors.xml (/home/username/.config/monitors.xml) (http://pastebin.com/ZKTPWpeX)


Then I put it in /etc/gnome-settings-daemon/xrandr/
and modify some options by hand
http://pastebin.com/A2TXbxUv
System wide config looks only first configuration section

So I have my favorite configuration 
 Cloned gdm display and spaned user display

Also I change some variables in /etc/gconf/schemas/apps_gnome_settings_daemon_xrandr.schemas from false to true.

Great thanks to Matej Cepl and Mamoru Tasaka 
https://bugzilla.redhat.com/show_bug.cgi?id=623824#c15

It will be great if system wide monitors.xml can be generated from some GUI

Comment 7 ati.x600.fedora.14 2010-11-09 21:40:08 UTC
(In reply to comment #3)
> gnome-desktop-properties (note the button "Make Default").
I noted it only when I solved this
"He that has ears to hear, let him hear"

Comment 8 ati.x600.fedora.14 2010-11-09 23:33:04 UTC
Without nomodeset in text mode console on VGA still doesnt work.

Comment 9 Matěj Cepl 2010-11-10 09:20:51 UTC
(In reply to comment #4)
> With nomodeset Xorg crash either with xorg.conf either without

If it works in KMS and doesn't work w/o we usually don't care that much ... nomodeset is just a crutch for situations when KMS doesn't work.

> Without nomodeset Xorg work but CRT monitor stays off till I login and  turns
> off when i log out.
> with gnome-desktop-properties LG CRT monitor (F720P) set as first
> 1024x768@85Hz,
> Sony TV placed in the right of LG and set as 1360x768@60Hz 

This looks really like a bug 623824.

Comment 10 Matěj Cepl 2010-11-10 09:22:05 UTC
Closing again. This actually IS a duplicate.

*** This bug has been marked as a duplicate of bug 623824 ***

Comment 11 ati.x600.fedora.14 2010-11-11 15:53:12 UTC
In text-console fixed with
1)read http://nouveau.freedesktop.org/wiki/KernelModeSetting
2)ls /sys/class/drm/card*/*
This give us name of video outs in text mode (differs from graphic mode).
3)add video=SVIDEO-1:d video=VGA-1024x768@85 to kernel in /boot/grub/grub.cfg

Is it possible to have GUI or TUI for this?


Note You need to log in before you can comment on or make changes to this bug.