Bug 651787 - bacula's alternatives links wrong
Summary: bacula's alternatives links wrong
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bacula
Version: 6.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Jan Görig
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
: 728164 911577 (view as bug list)
Depends On: 1626871
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-10 09:55 UTC by Leon Fauster
Modified: 2018-12-05 10:03 UTC (History)
6 users (show)

Fixed In Version: bacula-5.0.0-8.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, when creating a symbolic link to the "bscan" utility, the new link was erroneously named "dbcheck". As a result, the already existing "dbcheck" symbolic link was overwritten by the erroneous one. Thus the "dbcheck" command ran the "bscan" utility so that it was not possible to execute the "bscan" utility with the "bscan" command. The problem has been fixed in this update so that the "dbcheck" and "bscan" utilities now work as expected.
Clone Of:
Environment:
Last Closed: 2011-08-31 09:16:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1232 normal SHIPPED_LIVE bacula bug fix update 2011-08-31 09:16:01 UTC

Description Leon Fauster 2010-11-10 09:55:34 UTC
===================================
Description of problem:

the "alternatives" command in the post area of the spec file line 706, 711, 716
are linking "/usr/sbin/dbcheck" to /usr/sbin/bscan.postgresql|sqlite|mysql ??

It should be "/usr/sbin/bscan" ...


===================================
Version-Release number of selected component (if applicable):
5.0.0-7.el6

Comment 3 Suzanne Yeghiayan 2011-02-15 21:45:03 UTC
This issue was proposed for RHEL 6.1 FasTrack but did not get resolved in time.
It has been moved to RHEL 6.2 FasTrack.

Comment 7 Jan Görig 2011-06-08 15:52:47 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
- 'dbcheck' symlink pointed incorrectly to 'bscan'
- 'bscan' symlink wasn't created
Consequence
- 'dbcheck' command runs 'bscan' utility
- 'bscan' couldn't be run with 'bscan' command
Fix
- 'bscan' links correctly to 'bscan' utility
Result
- 'dbcheck' and 'bscan' can be started with appropriate commands

Comment 11 Petr Kovar 2011-06-15 16:06:42 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,10 +1 @@
-Cause
+Prior to this update, the "dbcheck" symbolic link pointed incorrectly to the "bscan" utility. As a result, the symbolic link for the "bscan" utility was not created, and the "dbcheck" command ran the "bscan" utility so that it was not possible to execute the "bscan" utility with the "bscan" command. The problem has been fixed in this update, and the "bscan" symbolic link now correctly links to the "bscan" utility so that the "dbcheck" and "bscan" utilities now works as expected.-- 'dbcheck' symlink pointed incorrectly to 'bscan'
-- 'bscan' symlink wasn't created
-Consequence
-- 'dbcheck' command runs 'bscan' utility
-- 'bscan' couldn't be run with 'bscan' command
-Fix
-- 'bscan' links correctly to 'bscan' utility
-Result
-- 'dbcheck' and 'bscan' can be started with appropriate commands

Comment 12 Petr Kovar 2011-06-23 15:58:35 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Prior to this update, the "dbcheck" symbolic link pointed incorrectly to the "bscan" utility. As a result, the symbolic link for the "bscan" utility was not created, and the "dbcheck" command ran the "bscan" utility so that it was not possible to execute the "bscan" utility with the "bscan" command. The problem has been fixed in this update, and the "bscan" symbolic link now correctly links to the "bscan" utility so that the "dbcheck" and "bscan" utilities now works as expected.+Prior to this update, when creating a symbolic link to the "bscan" utility, the new link was erroneously named "dbcheck". As a result, the already existing "dbcheck" symbolic link was overwritten by the erroneous one. Thus the "dbcheck" command ran the "bscan" utility so that it was not possible to execute the "bscan" utility with the "bscan" command. The problem has been fixed in this update so that the "dbcheck" and "bscan" utilities now work as expected.

Comment 13 Lukáš Nykrýn 2011-08-15 08:08:41 UTC
*** Bug 728164 has been marked as a duplicate of this bug. ***

Comment 15 errata-xmlrpc 2011-08-31 09:16:55 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1232.html

Comment 16 Petr Hracek 2013-02-18 09:30:30 UTC
*** https://bugzilla.redhat.com/show_bug.cgi?id=911577 has been marked as a duplicate of this bug. ***

Comment 17 Petr Hracek 2013-02-18 09:38:05 UTC
*** Bug 911577 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.