Bug 911577 - bad symlink /usr/sbin/dbcheck
Summary: bad symlink /usr/sbin/dbcheck
Keywords:
Status: CLOSED DUPLICATE of bug 651787
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bacula
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Petr Hracek
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-15 12:09 UTC by Johnny Hughes
Modified: 2013-02-18 09:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-18 09:38:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CentOS 0005260 None None None Never

Description Johnny Hughes 2013-02-15 12:09:24 UTC
Description of problem:
Installing bacula-storage-mysql-5.0.0-7.el6.x86_64 sets a symlink
/usr/sbin/dbcheck -> /etc/alternatives/bacula-bscan
This is wrong and causes various malfunctions, such as the script make_catalog_backup.pl failing with a confusing error message claiming that -B was an invalid option for the dbcheck command.

Steps to Reproduce:
1. yum install bacula-director-mysql
2. yum install bacula-storage-mysql
3. ls -l /usr/sbin/dbcheck

Additional Info:
Installing bacula-director-mysql creates the correct symlink:
/usr/sbin/dbcheck -> /etc/alternatives/bacula-dbcheck
Installing bacula-storage-mysql should leave that alone and create the symlink:
/usr/sbin/bscan -> /etc/alternatives/bacula-bscan
The problem appears to be caused by a typo in the postinstall scriptlet of package bacula-storage-mysql which says "--slave /usr/sbin/dbcheck" instead of "--slave /usr/sbin/bscan".

Comment 2 Petr Hracek 2013-02-18 09:38:05 UTC

*** This bug has been marked as a duplicate of bug 651787 ***


Note You need to log in before you can comment on or make changes to this bug.