Bug 651823 - please update to syslog-ng version 3.2
Summary: please update to syslog-ng version 3.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: syslog-ng
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 695975
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-10 11:43 UTC by Peter Czanik
Modified: 2011-05-19 05:05 UTC (History)
4 users (show)

Fixed In Version: syslog-ng-3.2.3-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 05:05:20 UTC


Attachments (Terms of Use)
Syslog-ng update from 3.1.1 to 3.1.4 (3.13 KB, patch)
2011-04-13 21:16 UTC, Jose Pedro Oliveira
no flags Details | Diff
minor changes to the syslog-ng 3.2.2-2 specfile (1.21 KB, patch)
2011-04-22 18:58 UTC, Jose Pedro Oliveira
no flags Details | Diff
minor changes to the syslog-ng 3.2.2-3 specfile (1.18 KB, patch)
2011-04-23 15:38 UTC, Jose Pedro Oliveira
no flags Details | Diff
major changes to the syslog-ng 3.2.2 specfile (3.34 KB, patch)
2011-04-23 21:24 UTC, Jose Pedro Oliveira
no flags Details | Diff
[PATCH] syslog-ng: systemd changes (Bill Nottingham) (1.08 KB, application/octet-stream)
2011-05-06 01:17 UTC, Jose Pedro Oliveira
no flags Details

Description Peter Czanik 2010-11-10 11:43:29 UTC
A new syslog-ng release is expected to arrive in a few weeks, version 3.2. As this release brings many changes (for details, see: http://bazsi.blogs.balabit.com/2010/10/syslog-ng-ose-3-2beta1-released/ ) we ask distribution package maintainers to update their syslog-ng packages before it is released. This way we can fix problems, integrate patches from distributions before the release is done.

The latest release is beta1: http://www.balabit.com/downloads/files?path=/syslog-ng/sources/3.2beta1/source

But git has many small fixes since that release: http://git.balabit.hu/?p=bazsi/syslog-ng-3.2.git;a=summary

The main changes from the packaging point of view are:
- modularization
- SCL
- SELinux might need a few more rules

Please let me know, if you need any more information!

Comment 1 Peter Czanik 2010-12-02 13:42:40 UTC
Syslog-ng version 3.2 is released:
http://bazsi.blogs.balabit.com/2010/11/syslog-ng-3-2-1-released/
Please update syslog-ng to this version.

Comment 2 Jose Pedro Oliveira 2011-04-13 01:19:50 UTC
The latest upstream version is 3.2.2:
http://www.balabit.com/downloads/files?path=/syslog-ng/sources/3.2.2/source

Comment 3 Jose Pedro Oliveira 2011-04-13 21:16:58 UTC
Created attachment 491907 [details]
Syslog-ng update from 3.1.1 to 3.1.4

This patch not only updates syslog-ng from version 3.1.1 to 3.1.4 but also starts to drop support for EPEL-4 and EPEL-5 as syslog-ng >= 3.0 requires pcre >= 7.3.

Comment 4 Jose Pedro Oliveira 2011-04-13 21:20:41 UTC
Task list to be done later:
 - continue to clean the specfile (drop support for EPEL-4 and EPEL-5)
 - update to version 3.2.2
 - enable SSL support (I believe this can be done by statically linking openssl)
 - conditional enable SQL support (problem as libdbi resides in /usr/{lib,lib64})
 - maybe enable linux caps

/jpo

Comment 5 Jose Pedro Oliveira 2011-04-13 21:21:53 UTC
Added a dependency on ticket #695975 (eventlog update).

Comment 6 Matthias Runge 2011-04-14 08:40:58 UTC
jpo,

(just for your information)

I did already a build for version 3.2.2. based on eventlog-0.2.12
Binaries are here: http://www.matthias-runge.de/fedora/

I'll have a look onto it regarding SSL, libdbi, etc.

Comment 7 Jose Pedro Oliveira 2011-04-22 18:58:01 UTC
Created attachment 494294 [details]
minor changes to the syslog-ng 3.2.2-2 specfile

Comment 8 Jose Pedro Oliveira 2011-04-22 19:05:23 UTC
Matthias,

The patch attached to comment 7 makes a couple of small changes to the syslog-ng 3.2.2-2 specfile:

 * drops the release number from the eventlog version requirement (evtlog_ver)
 * the script contrib/relogger.pl interpreter has being changed twice
   (kept the one in the %prep section)
 * updated the vim versions supported: added version 72 and 73;
   dropped supported for versions 6x (long due)

Could you also use a public tarball (from http://www.balabit.com/downloads/files?path=/syslog-ng/sources/3.2.2/source) and drop the one made from git?
This should also imply the drop of the autoconf/automake BR and the execution of the autogen.sh script.

Tia,
jpo

Comment 9 Matthias Runge 2011-04-23 13:13:06 UTC
Jose,

I incorporated your suggestions. I would like to build the package from public available tarball. But afaik, ther version from tarball does not support systemd.
Off course, we don't need autoconf/automake etc. 

If I remember right, there has been a linking error; this may caused by an old version of eventlog, but also by a missing dependency to glib.

If that's a real problem, I'll investigate this further. This should be fixed for syslog-ng.3.2.3 (once it gets released)

Comment 10 Jose Pedro Oliveira 2011-04-23 15:38:23 UTC
Created attachment 494440 [details]
minor changes to the syslog-ng 3.2.2-3 specfile

Minor changes to the syslog-ng specfile

Comment 11 Jose Pedro Oliveira 2011-04-23 15:47:27 UTC
Matthias, 

Could you review and commmit the changes in the syslog-ng-322-3-specfile-minor-changes patch?

 * moves the invocation of autogen.sh to the %build block (before %configure)
 * removes the last line from the old spoofsource conditional support
   (since libnet has been moved to /lib{,64} is become a mandatory requirement)
 * contrib/relogger.pl no longer needs to have its permissions fixed
 * moved the permissions fixing instructions to the %prep block and added
   the -c option to the chmod command (verbose changes in the build log)


Additionally, could you also remove the files below from the master branch?

 * syslog-ng.vim (shipped in the syslog-ng tarball)
 * syslog-ng-2.1.4-libnet.patch (no longer necessary)


After these changes I will post a couple more (and more important ones).

/jpo

PS - No need to build a new version of syslog-ng; the build can wait for the next patch.

Comment 12 Jose Pedro Oliveira 2011-04-23 16:29:27 UTC
Matthias,

This change will also have to be reverted:

-%define logrotated_dst syslog
+%define logrotated_dst syslog-ng

The parallel installation of rsyslog/sysklogd/syslog-ng requires the same default logrotate file (same MD5 digest).

jpo

Comment 13 Jose Pedro Oliveira 2011-04-23 19:29:47 UTC
Another change that needs to be reverted (critical):

-Provides: syslog


This "provides" needs to be provided by every package providing a syslog daemon (sysklogd/rsyslog/syslog-ng). Every system needs at least one package providing "syslog" (eg: yum install syslog-ng; rpm -e rsyslog).

/jpo

grep for "Provides: syslog":
----------
rsyslog/rsyslog-4.6.3-1.fc14.src/rsyslog.spec:Provides: syslog
rsyslog/rsyslog-4.4.2-6.fc13.src/rsyslog.spec:Provides: syslog
rsyslog/rsyslog-5.7.9-2.fc15.src/rsyslog.spec:Provides: syslog
rsyslog/rsyslog-4.6.3-2.fc14.src/rsyslog.spec:Provides: syslog
rsyslog/rsyslog-4.6.2-2.el6.src/rsyslog.spec:Provides: syslog

sysklogd/sysklogd-1.4.1-46.el5.src/sysklogd.spec:Provides: syslog
sysklogd/sysklogd-1.5-9.fc12.fc13.src/sysklogd.spec:Provides: syslog
sysklogd/sysklogd-1.5-9.fc12.fc14.src/sysklogd.spec:Provides: syslog
sysklogd/sysklogd-1.5-10.fc15.src/sysklogd.spec:Provides: syslog


syslog-ng/syslog-ng-2.1.4-1.el5.src/syslog-ng.spec:Provides: syslog
syslog-ng/syslog-ng-2.1.4-6.fc12.src/syslog-ng.spec:Provides: syslog
syslog-ng/syslog-ng-3.1.1-1.fc14.src/syslog-ng.spec:Provides: syslog
syslog-ng/syslog-ng-3.1.1-2.fc15.src/syslog-ng.spec:Provides: syslog
----

Comment 14 Matthias Runge 2011-04-23 19:45:44 UTC
Jose,

did you mean, the define should now read

%define logrotated_dst syslog-ng 

or did I misunderstood you?

I applied those changes. I am aware, those ifs in %post, %preun and %postun don't fit for epel package. I'm thinking about renaming files to more matching names. Last, I will postpone the F15 build as long as there are changes in the spec.

Matthias

Comment 15 Jose Pedro Oliveira 2011-04-23 20:11:43 UTC
(In reply to comment #14)
> Jose,
> 
> did you mean, the define should now read
> 
> %define logrotated_dst syslog-ng 
> 
> or did I misunderstood you?

See patch below.

> 
> I applied those changes. I am aware, those ifs in %post, %preun and %postun
> don't fit for epel package. I'm thinking about renaming files to more matching
> names. Last, I will postpone the F15 build as long as there are changes in the
> spec.

I will get there ;)


Here is the patch (that reverts a couple of changes you made during the specfile update from 3.1.1 to 3.2.2):

 * brings the "Provides: syslog"
 * renames the logrotate file back to syslog
   (note: logrotate breaks when 2 of more logrotate.d files try to rotate
    the same file).
 
----------
diff --git a/syslog-ng.spec b/syslog-ng.spec
index a6adb72..bd1b9d8 100644
--- a/syslog-ng.spec
+++ b/syslog-ng.spec
@@ -51,6 +51,7 @@ Requires(preun): /sbin/chkconfig
 Requires(preun): /sbin/service
 Requires(postun): /sbin/service
 
+Provides: syslog
 # merge separate syslog-vim package into one
 Provides: syslog-ng-vim = %{version}-%{release}
 Obsoletes: syslog-ng-vim < 2.0.8-1
@@ -85,7 +86,7 @@ developing applications that use %{name}.
 # fix executable perms on contrib files
 %{__chmod} -c a-x contrib/syslog2ng
 
-%define logrotated_dst syslog-ng
+%define logrotated_dst syslog
 %if 0%{?rhel}
        %if 0%{?rhel} >= 5
                %define sysconfig_src %{SOURCE10}
----------

/jpo

Comment 16 Jose Pedro Oliveira 2011-04-23 20:17:18 UTC
Matthias,

To reproduce the logrotate problem just try:

 * cd /etc/logrotate.d/
 * cp -p syslog syslog-ng
 * logrotate -f /etc/logrotate.conf

You will get something like:
----------
# logrotate -f /etc/logrotate.conf
error: syslog-ng:1 duplicate log entry for /var/log/messages
error: found error in /var/log/messages /var/log/secure /var/log/maillog
/var/log/spooler /var/log/boot.log /var/log/cron , skipping

# echo $?
1
----------


/jpo

Comment 17 Jose Pedro Oliveira 2011-04-23 20:51:05 UTC
BTW the patch in comment 15 removes two "blockers".

And now we will clean the sysconfig and logrotate files mess:

NOTE: targetting only Fedora >= 13 and EPEL >= 6 for syslog-ng 3.x

1) shipped logrotate files MD5 digest:

----------
bc0ba49b28deea39dd96e1dfdf33f691  sysklogd-1.5-9.fc12.fc13.src/sysklogd-1.5.logrotate
bc0ba49b28deea39dd96e1dfdf33f691  sysklogd-1.5-9.fc12.fc14.src/sysklogd-1.5.logrotate
bc0ba49b28deea39dd96e1dfdf33f691  sysklogd-1.5-10.fc15.src/sysklogd-1.5.logrotate

2750ccba4b19b61b8a49e39b6b2b5359  rsyslog-4.4.2-6.fc13.src/rsyslog.log
2750ccba4b19b61b8a49e39b6b2b5359  rsyslog-4.6.2-2.el6.src/rsyslog.log
2750ccba4b19b61b8a49e39b6b2b5359  rsyslog-4.6.3-1.fc14.src/rsyslog.log
2750ccba4b19b61b8a49e39b6b2b5359  rsyslog-4.6.3-2.fc14.src/rsyslog.log
2750ccba4b19b61b8a49e39b6b2b5359  rsyslog-5.7.9-2.fc15.src/rsyslog.log
----------

2) diff between the sysklogd and rsyslog logrotate files is not critical
   as the default logrotate configuration rotates files every week.

----------
--- sysklogd/sysklogd-1.5-9.fc12.fc14.src/sysklogd-1.5.logrotate»···2008-08-24 21:25:54.000000000 +0100
+++ rsyslog/rsyslog-4.6.3-2.fc14.src/rsyslog.log»···2010-09-09 07:26:16.000000000 +0100
@@ -1,5 +1,4 @@
 /var/log/messages /var/log/secure /var/log/maillog /var/log/spooler /var/log/boot.log /var/log/cron {
-    weekly
     sharedscripts
     postrotate
 »··/bin/kill -HUP `cat /var/run/syslogd.pid 2> /dev/null` 2> /dev/null || true
----------


3) the difference between the sysklogd and the rsyslog logrotate file is not
   critical as the default logrotate configuration rotates files every week.

   $ head -n 3 /etc/logrotate.conf
   ---------
   # see "man logrotate" for details
   # rotate log files weekly
   weekly

   ---------

4) The current logrotates files in the git repo have the following MD5 digests:

   $ md5sum *log
   dee670db412fbf7e1b61442a39bab4d4  sysklogd-1.4.1-44-logrotate.d-syslog.log
   2750ccba4b19b61b8a49e39b6b2b5359  rsyslog-3.21.9-logrotate.d-rsyslog.log
   2750ccba4b19b61b8a49e39b6b2b5359  sysklogd-1.4.1-logrotate.d-syslog.log

5) sysklogd-1.4.1-44-logrotate.d-syslog.log can be removed as you are
   no longer targeting EPEL5 (pcre >= 7.3 not available).

   The other two are the same and have the same MD5 digest. So removing
   sysklogd-1.4.1-logrotate.d-syslog.log and renaming rsyslog-3.21.9-logrotate.d-rsyslog.log to syslog-ng.logrotate


The *.sysconfig files were the same (until today). We only need to keep one around (is manadatory that the PID file is /var/run/syslogd.pid).



Matthias,
Why the change made a couple of hours ago in
http://lists.fedoraproject.org/pipermail/scm-commits/2011-April/595955.html ?


/jpo

Comment 18 Jose Pedro Oliveira 2011-04-23 21:24:57 UTC
Created attachment 494460 [details]
major changes to the syslog-ng 3.2.2 specfile

Comment 19 Jose Pedro Oliveira 2011-04-23 21:27:14 UTC
Matthias,

The patch attached to the comment 18 incorporates the critical changes mentioned in comment 15 and cleans the sysconfig and logrotate files mess.

Could you apply it and make a new syslog-ng koji build?

tia,
/jpo

Comment 20 Jose Pedro Oliveira 2011-04-23 21:28:37 UTC
(In reply to comment #19)
> Matthias,
> 
> The patch attached to the comment 18 incorporates the critical changes
> mentioned in comment 15 and cleans the sysconfig and logrotate files mess.
> 
> Could you apply it and make a new syslog-ng koji build?
> 
> tia,
> /jpo


Forgot to mention that you also need to do the following:

 * remove the files sysklogd-*

   rm sysklogd-*

 * rename the rsyslog-* files

   mv rsyslog-syslog-ng-fc10.sysconfig syslog-ng.sysconfig
   mv rsyslog-3.21.9-logrotate.d-rsyslog.log syslog-ng.logrotate


/jpo

Comment 21 Jose Pedro Oliveira 2011-04-25 15:34:12 UTC
Summary:

 * Provides: syslog

   Everything package providing a syslog compatible daemon should provide
   this virtual (and package neutral) provide. It is currently provided
   by the rsyslog/sysklogd/syslon-ng packages.

   Every package that requires a syslog daemon should require this neutral
   one, thus avoiding requiring a specific one like rsyslog.  It is currently
   required by the cron daemons.

      $ repoquery --whatrequires syslog
      cronie-0:1.4.7-1.fc15.x86_64
      fcron-0:3.0.5-2.fc15.x86_64
  

 * logrotate file

   In order to avoid breaking the logrotate cron task and avoid file conflicts
   when installing more than one syslog daemon we need to ship the same
   logrotate file being used by the default syslog daemon (currently rsyslog). 
   This requires that:

     - we have similar configuration files for each daemon, i.e., we create
       the same destination log files
     - the syslog daemons use the same pid file

   Right one the sysklog daemon can't even be installed in parallel with
   rsyslog:
      # yum install sysklogd
      Loaded plugins: langpacks, presto, refresh-packagekit, security
      Setting up Install Process
      Resolving Dependencies
      --> Running transaction check
      ---> Package sysklogd.x86_64 0:1.5-10.fc15 will be installed
      --> Processing Conflict: sysklogd-1.5-10.fc15.x86_64 conflicts rsyslog
      --> Finished Dependency Resolution
      Error: sysklogd conflicts with rsyslog
      You could try using --skip-broken to work around the problem
      You could try running: rpm -Va --nofiles --nodigest

    I believe this conflict could be easily be resolved by shipping
    the same logrotate file that is shipped with rsyslog.

    TODO: check this and open a ticket against sysklogd;
    NOTE: EPEL6 doesn't appear to have sysklogd 


Another condition that must be met is that only the default system syslog
daemon (rsyslog) should be able to start by default, i.e., all the others
should ship init scripts without mentioning starting runlevels. Example
(from the syslog-ng init script).

   # chkconfig: - 12 88


PS - More information available in ticket #400661 (comments >= 16)

Comment 22 Jose Pedro Oliveira 2011-04-26 01:33:17 UTC
Tasks completed:

 * applied the pending patch 
     "https://bugzilla.redhat.com/attachment.cgi?id=494460"
   plus some minor updates and built it as syslog-ng-3.2.2-4.fc16
     "https://bugzilla.redhat.com/attachment.cgi?id=494460"

 * changed the NVR to alert users that we have been using a syslog-ng v3.2
   git snapshot (for systemd support); built as syslog-ng-3.2.3-0.20110424.1.fc16
     "http://koji.fedoraproject.org/koji/buildinfo?buildID=240628"

 * built syslog-ng-3.1.4-2 for EPEL6 (tracking ticket #699541)

/jpo

Comment 23 Fedora Update System 2011-04-27 07:29:43 UTC
syslog-ng-3.2.3-0.20110424.2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/syslog-ng-3.2.3-0.20110424.2.fc15

Comment 24 Jose Pedro Oliveira 2011-04-27 13:49:07 UTC
Matthias,

[MID-AIR COLLISION / and maybe to late ?]

I have just added negative karma to syslog-ng-3.2.3-0.20110424.2.fc15 as
syslog-ng isn't creating a pidfile. You need a "-p /var/run/syslogd.pid" in
SYSLOGNG_OPTIONS.


/lib/systemd/system/syslog-ng.service
----------
...
ExecStart=/sbin/syslog-ng $SYSLOGNG_OPTIONS
...
----------

cat /etc/sysconfig/syslog-ng
----------
SYSLOGNG_PID="/var/run/syslog-ng.pid"
SYSLOGNG_OPTIONS="-F"
SYSLOGNG_COMPAT_PID="/var/run/syslogd.pid"
----------

Note: i don't think we will be able to maintain backwards compatibility with
the 2 pidfiles (bug #699541 comments 9 and 10).


/jpo

Comment 25 Jose Pedro Oliveira 2011-04-27 14:26:40 UTC
Also regarding the Fedora 15 build:

For the time being, and until with we move some of the syslog-ng modules to subpackages [1], I would vote for a F-15 build without SSL and SQL enabled.

Currently, enabling SSL (--enable-ssl; BR: openssl-devel) and SQL (--enable-sql; BR: libdbi-devel) creates two additional modules 

   * lib[64]/syslog-ng/libafsocket-tls.so
   * lib[64]/syslog-ng/libafsql.so

that require libraries installed in /usr/lib{,64}:

   # ldd libafsocket-tls.so | grep "/usr/lib"
       libssl.so.10 => /usr/lib64/libssl.so.10 (0x...)

   # ldd libafsql.so | grep "/usr/lib"
       libdbi.so.0 => /usr/lib64/libdbi.so.0 (0x...)

also, the openssl presence appears to change the way libdbparser.so
is built:

   # ldd libdbparser.so | grep "/usr/lib"
       libssl.so.10 => /usr/lib64/libssl.so.10 (0x...)



The main idea would be for a main core syslog-ng package free of /usr/lib{,64} libraries dependencies.

Comments on this one?

jpo

[1] - rsyslog has several subpackages: rsyslog-gnutls, rsyslog-gssapi, rsyslog-libdbi, ...

Comment 26 Jose Pedro Oliveira 2011-04-27 18:15:02 UTC
PCRE: minimal version
---------------------

The commit "http://git.balabit.hu/?p=bazsi/syslog-ng-3.2.git;a=commit;h=141aca6110e64d6b030045cd1db51cfcde2b3ecc" downgrades the pcre minimal required version from 7.3 to 6.1 (syslog-ng 3.2.3+ configure.in).

It may be possible to also build syslog-ng 3.2.3 fro EPEL-5 (includes pcre 6.6).

Comment 27 Matthias Runge 2011-04-28 06:45:44 UTC
(In reply to comment #24)
> 
> Note: i don't think we will be able to maintain backwards compatibility with
> the 2 pidfiles (bug #699541 comments 9 and 10).
> 
> 
> /jpo
Systemd oputs running services in cpu-control-groups. It creates a group for each service and starts its processes. When the group is empty, the process died. Thus systemd will restart the service.

When you need more than one instance running, this must end in more than one service file (afaik).

Comment 29 Jose Pedro Oliveira 2011-04-28 17:31:27 UTC
Problem free logrotation tasks can be accomplished using syslog-ng builds

 * syslog-ng-3.2.3-0.20110424.3.fc15, and
 * syslog-ng-3.2.3-0.20110424.4.fc16 (with a local F15 mock build)

Note: The build syslog-ng-3.2.3-0.20110424.3 restored the creation of the /var/run/syslogd.pid pid file. 


ps aux:

 * /sbin/syslog-ng -F -p /var/run/syslogd.pid

logrotate -f /etc/logrotate.conf

 * log files correctly rotated
 * log entry in the new /var/log/message file:
   "... syslog-ng[3142]: Configuration reload request received, reloading configuration;"

Comment 30 Jose Pedro Oliveira 2011-04-28 17:37:10 UTC
Strange log message produced during a syslog-ng upgrade (via rpm -F ...):

Apr 28 17:48:28 zzz syslog-ng[17288]: syslog-ng shutting down; version='3.2.2'
Apr 28 17:48:28 zzz syslog-ng[3142]: The current log file has a mismatching size/inode information, restarting from the beginning; state='affile_sd_curpos(/proc/kmsg)', stored_inode='-268435252', cur_file_inode='-268435252', stored_size='0', cur_file_size='0', raw_stream_pos='1319'
Apr 28 17:48:28 zzz syslog-ng[3142]: syslog-ng starting up; version='3.2.2'

Comment 31 Matthias Runge 2011-04-28 18:38:04 UTC
Thank you for your feedback. I think, I'll report the last issue #30 upstream.
During my testing I saw those messages, too; I thought, this may be /proc/kmsg-related.

Answer from upstream regarding signalling syslog-ng without HUPing via pid:
------
> > It is based on a git-snapshot dated April 24th. Is there a way to signal
> > syslog-ng to reload it's configuration other than HUPing its pid?
To the best of my knowledge: no, there is not (yet). One way to remedy
this would be to enhance syslog-ng-ctl so it can signal (and wait for)
configuration reload.

I'm not sure how much work that would be, but my gut feeling is that it
would be reasonably easy and straightforward to do.

-------

Comment 32 Fedora Update System 2011-04-28 19:03:12 UTC
Package syslog-ng-3.2.3-0.20110424.3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing syslog-ng-3.2.3-0.20110424.3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/syslog-ng-3.2.3-0.20110424.3.fc15
then log in and leave karma (feedback).

Comment 33 Jose Pedro Oliveira 2011-05-02 04:51:35 UTC
(In reply to comment #30)
> Strange log message produced during a syslog-ng upgrade (via rpm -F ...):
> 
> Apr 28 17:48:28 zzz syslog-ng[17288]: syslog-ng shutting down; version='3.2.2'
> Apr 28 17:48:28 zzz syslog-ng[3142]: The current log file has a mismatching
> size/inode information, restarting from the beginning;
> state='affile_sd_curpos(/proc/kmsg)', stored_inode='-268435252',
> cur_file_inode='-268435252', stored_size='0', cur_file_size='0',
> raw_stream_pos='1319'
> Apr 28 17:48:28 zzz syslog-ng[3142]: syslog-ng starting up; version='3.2.2'

Should be solved by:
http://git.balabit.hu/?p=bazsi/syslog-ng-3.2.git;a=commit;h=a8e298f300ad29442cd6f0aee7de5956438658e7

Comment 34 Jose Pedro Oliveira 2011-05-02 05:02:38 UTC
I have just build syslog-ng 3.2.3 for rawhide:

 * syslog-ng-3.2.3-1.fc16
   http://koji.fedoraproject.org/koji/buildinfo?buildID=242025

Short-term task list:

 * test the package upgrade (comments 30 and 33)

 * add the new configure option --enable-systemd
   # Enable systemd support (default: auto)
   http://git.balabit.hu/?p=bazsi/syslog-ng-3.2.git;a=commit;h=c844bef80554d2b4dacd3796e0522f90b3721702

Comment 35 Jose Pedro Oliveira 2011-05-02 17:44:27 UTC
(In reply to comment #33)
> (In reply to comment #30)
> > Strange log message produced during a syslog-ng upgrade (via rpm -F ...):
> > 
> > Apr 28 17:48:28 zzz syslog-ng[17288]: syslog-ng shutting down; version='3.2.2'
> > Apr 28 17:48:28 zzz syslog-ng[3142]: The current log file has a mismatching
> > size/inode information, restarting from the beginning;
> > state='affile_sd_curpos(/proc/kmsg)', stored_inode='-268435252',
> > cur_file_inode='-268435252', stored_size='0', cur_file_size='0',
> > raw_stream_pos='1319'
> > Apr 28 17:48:28 zzz syslog-ng[3142]: syslog-ng starting up; version='3.2.2'
> 
> Should be solved by:
> http://git.balabit.hu/?p=bazsi/syslog-ng-3.2.git;a=commit;h=a8e298f300ad29442cd6f0aee7de5956438658e7


# rpm -Fvh syslog-ng-3.2.3-1.fc15.x86_64.rpm
...
May  2 18:42:04 host systemd[1]: Reloading.
May  2 18:42:05 host syslog-ng[863]: Termination requested via signal, terminating;
May  2 18:42:05 host syslog-ng[863]: syslog-ng shutting down; version='3.2.2'
May  2 18:42:05 host syslog-ng[3802]: syslog-ng starting up; version='3.2.3'
...

Comment 36 Matthias Runge 2011-05-02 18:54:26 UTC
Oh, great to hear. Thank you. I'll update F15 tree to version 3.2.3 as soon as I can. I think, we should push this version then to updates (when it went through updates-testing).

What do you think about trying the 3.3 series in rawhide? I would build this too.

Comment 37 Fedora Update System 2011-05-02 19:25:00 UTC
syslog-ng-3.2.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/syslog-ng-3.2.3-1.fc15

Comment 38 Jose Pedro Oliveira 2011-05-02 21:12:06 UTC
(In reply to comment #36)
> ...
> 
> What do you think about trying the 3.3 series in rawhide? I would build this
> too.

Please no alpha versions.  Let's wait first for 3.2.4 (see https://lists.balabit.hu/pipermail/syslog-ng/2011-May/016517.html).

/jpo

Comment 39 Jose Pedro Oliveira 2011-05-06 01:17:30 UTC
Created attachment 497257 [details]
[PATCH] syslog-ng: systemd changes (Bill Nottingham)

Date: Thu, 5 May 2011 17:16:33 -0400
From: Bill Nottingham <notting_at_...>
To: syslog-ng-owner_at_...
Cc: lennart_at_...
Subject: [PATCH] syslog-ng: systemd changes

I'm doing an audit of packages with systemd service files, attempting
to make sure that they're properly handled for Fedora 15, and I have
the attached diff for your package.

I'm perfectly willing to do the push, build, and bodhi update for
this, but I want to make sure you're aware of this. I'd like to get
this in for the final change freeze on Monday, May 9th, so if you
see a problem with this, or a reason it shouldn't go in, please
let me know.

Bill

Comment 40 Jose Pedro Oliveira 2011-05-06 01:23:04 UTC
New syslog-ng build with Bill's patch

 * syslog-ng-3.2.3-2.fc16 
   http://koji.fedoraproject.org/koji/buildinfo?buildID=242639

Comment 41 Fedora Update System 2011-05-06 17:52:27 UTC
syslog-ng-3.2.3-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/syslog-ng-3.2.3-2.fc15

Comment 42 Jose Pedro Oliveira 2011-05-18 03:46:23 UTC
Testers needed for the latest rawhide build

 * syslog-ng-3.2.4-4.fc16 
   http://koji.fedoraproject.org/koji/buildinfo?buildID=244213

   First release with SQL support enabled; module shipped in the
   new subpackage syslog-ng-libdbi

and for the EPEL5 / EPEL6 builds

 * https://bugzilla.redhat.com/show_bug.cgi?id=699541#c22

/jpo

PS1: New EPEL5 and EPEL6 updates based on syslog-ng-3.2.4-3.fc16 are planned
     ( links in https://bugzilla.redhat.com/show_bug.cgi?id=699541#c21 )

PS2: Fedora 14 updates are problematic due to the new trigger
     (%triggerun -- syslog-ng < 3.2.3)

Comment 43 Fedora Update System 2011-05-19 05:05:14 UTC
syslog-ng-3.2.3-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.